Joomla 1.5 Расширения - совместимость компонента с Joomla 1.5

Тема в разделе "Программирование", создана пользователем amatory, 23.07.2009.

  1. Offline

    amatory Недавно здесь

    Регистрация:
    17.07.2009
    Сообщения:
    8
    Симпатии:
    0
    Здравствуйте. Потребовалось написать компонент для Joomla 1.5.7. Написал. Все работает, но в админке в Менеджер расширений там где совместимость стоит крестик(получается работает только вс включенным LEGACY-MODE). Подскажите что необходимо добавить в .xml файл установки что-бы joomla 1.5.7 его нормально приняла.
     
  2.  
  3. Dead Krolik
    Offline

    Dead Krolik специалист

    Регистрация:
    13.04.2007
    Сообщения:
    3 688
    Симпатии:
    101
    Пол:
    Мужской
    Re: Расширения

    Стоп. Как связан компонент и крестик где-то в админке. Ведь если крестик стоит, то компонент работает? И уточни что за крестик.
     
  4. Gronpipmaster
    Offline

    Gronpipmaster специалист

    Регистрация:
    21.01.2009
    Сообщения:
    1 392
    Симпатии:
    62
    Пол:
    Мужской
    Re: Расширения

    amatory, инсталяцию я как понял написали там надо вместо <mosinstall type="component">....</mosinstall> сделать <install type="component" version="1.5.0">....</install> или <install type="component" version="1.0.0"> на <install type="component" version="1.5.0"> заменить и все
     
  5. Offline

    amatory Недавно здесь

    Регистрация:
    17.07.2009
    Сообщения:
    8
    Симпатии:
    0
    Re: Расширения

    В Адимн панели Расширения=>Установить/Удалить=>Компоненты.
    Появляется таблица со списком компонентов. Там есть столбец `совместимость`. Вот там и стоит крестик(на против моего компонента).
     
  6. Offline

    amatory Недавно здесь

    Регистрация:
    17.07.2009
    Сообщения:
    8
    Симпатии:
    0
    Re: Расширения

    Увы.. Не помогло.
     

Поделиться этой страницей

Загрузка...