Joomla 1.5 Кодировка задана в htaccess, но браузер не понимает.

Тема в разделе "Кодировки, ошибки отображения (крякозябры)", создана пользователем Jazz12, 20.09.2009.

  1. Offline

    Jazz12 Недавно здесь

    Регистрация:
    20.09.2009
    Сообщения:
    1
    Симпатии:
    0
    Здравствуйте, уважаемые!

    Очень нужна ваша помощь, уже полдня сижу не могу решить проблему с кодировкой.
    Сайт d-parts.ru
    Непонятно из-за чего вдруг браузер перестал автоматом определять кодировку, сам ставит windows-1251 и все в крякозябрах, что Firefox, что IE. Что самое интересное - могу несколько кликов сделать по меню - все нормально, но потом вдруг все слетает, кодировка меняется на 1251. И может также вернуться в нормальное состояние utf-8 через некоторое время.
    В htaccess прописал
    AddDefaultCharset utf-8
    AddType "text/html; charset=utf-8" .html .htm .shtml

    - не помогло

    Прописал в индексе шаблона
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

    - не помогло.

    MySQL-кодировка: UTF-8 Unicode (utf8)

    В базе mysql есть колонки Сравнение, так вот большинство utf8_general_ci, но есть несколько cp1251_general_ci

    С чем связаны такие скачки кодировки?
    Спасибо.
     
  2.  
  3. Offline

    tselofan Недавно здесь

    Регистрация:
    05.02.2010
    Сообщения:
    4
    Симпатии:
    0
    Пол:
    Мужской
    Таж проблема.. Правда более уточненная - неправильная кодировка возникает только при форме добавления новой статьи.. Все что описано раннее также проделано.
     
  4. Kadavr
    Offline

    Kadavr специалист

    Регистрация:
    18.10.2007
    Сообщения:
    557
    Симпатии:
    39
    Пол:
    Мужской
    Скорее всего - с базой данных и связано. Сделайте дамп базы, удалите базу и создайте снова из дампа, указав ее кодировку utf-8.
     

Поделиться этой страницей

Загрузка...