Joomla 1.5 Пропали изображения товаров: в описании товара картинки есть, а в магазине - нет!

Тема в разделе "Магазины, электронная коммерция", создана пользователем Shaltai, 28.10.2009.

  1. Offline

    Shaltai Недавно здесь

    Регистрация:
    28.10.2009
    Сообщения:
    8
    Симпатии:
    0
    Пол:
    Женский
    [!!!]Пропали изображения товаров. В Панели Администрирования/Список товаров/ в описании позиции картинки видны (и большие, и маленькие), а в самом магазине их не видно. Перезаливаю картинку - никакого эффекта.
    Если нажать на "увеличить" под тем местом, где должно быть изображение товара, то оно появляется.
    Картинки категорий отображаются нормально.
    В чем может быть проблема?
    Вдруг поможет пролить свет: если поставить галочку на "включить динамическое изменение размеров для мини-изображения", то теперь пропадают и картинки категорий (раньше такого не было). :'(

    Вот как это выглядит: http://www.zooluxx.ru/
     
  2.  
  3. Offline

    respecT_T Недавно здесь

    Регистрация:
    28.10.2009
    Сообщения:
    1
    Симпатии:
    0
    Пол:
    Мужской
    У меня сегодня произошла похожая проблема!
    только вот у меня пропало всё, и даже изображение категорий и под категорий, вообщем все картинки те что находились в виртуемарте... всё это случилось после переноса на Виртуальный Хостинг, на Денвере всё чудесно! Весь день потратил, но так и не нарыл ничего...буду признателен кто поможет нам, видимо эта проблема толком нигде не описана!!!
     
  4. Offline

    Shaltai Недавно здесь

    Регистрация:
    28.10.2009
    Сообщения:
    8
    Симпатии:
    0
    Пол:
    Женский
    В том-то и дело, что у меня не было переноса - черт знает откуда сбой.
    Не видны именно МИНИ-ИЗОБРАЖЕНИЯ - с увеличенными картинками все в порядке!!!
    И в папке ресайз они есть, но в магазе не видны - и все тут! Что за фигня? :hz:
     
  5. Offline

    Shaltai Недавно здесь

    Регистрация:
    28.10.2009
    Сообщения:
    8
    Симпатии:
    0
    Пол:
    Женский
    Решено. Гацкие какеры ]:>
     
  6. Offline

    KingGod Недавно здесь

    Регистрация:
    03.05.2009
    Сообщения:
    1
    Симпатии:
    0
    Пол:
    Мужской
    Подскажите как решили проблему!У меня аналогичная проблема, картинки пропали не с того не с сего...Все изображение в virtuemart исчезли, только нажимая на увеличить появляется большая картинка.Права на папки 777, картинки на сервере есть, если задать адрес картинки в браузере то всё в порядке картинка отображается.
     
    Последнее редактирование: 20.01.2010
  7. Offline

    Вадим Недавно здесь

    Регистрация:
    27.01.2010
    Сообщения:
    1
    Симпатии:
    0
    Пол:
    Мужской
    Аналогичная проблема как и у KingGod. При этом в файерфоксе и сафари картинки отображаются, опера и эксплорер не хочет (( Прошу помощи!
     
  8. Offline

    Vitali777 Недавно здесь

    Регистрация:
    04.05.2010
    Сообщения:
    7
    Симпатии:
    0
    Пол:
    Мужской
    Shaltai, я не понимаю, что за прикол - решить проблему и не отписать о её решении на форуме.
    за такое хорошо бы ставить предупреждения! или бан!
     
  9. Offline

    Nomade Недавно здесь

    Регистрация:
    27.10.2010
    Сообщения:
    1
    Симпатии:
    0
    Пол:
    Мужской
    Очень познавательно читать сообщения вроде "Все! Решено" :)
    Заставляет думать и верить, что решение таки есть.
    Теперь моя ситуация.
    После очередных испытаний на локальном, вдруг пропали мини-изображения в списке товаров (через browse_listtable.tpl.php) Никаких ошибок-просто пустое место. По ссылке уходило на увеличенное изображение - то есть вроде работало . Замена на browse_layouttable.tpl.php ни к чему не привела - та же фигня - картинок нет. Поискав наудачу в инете, ниче не нашел кроме ""Все! Решено"
    Путем перестановок в коде, заставил таки показать ошибку:

    Warning: Cannot modify header information - headers already sent by (output started at /srv/www/joomla/administrator/components/com_virtuemart/virtuemart.cfg.php:165) in /srv/www/joomla/components/com_virtuemart/show_image_in_imgtag.php on line 140

    virtuemart.cfg.php и show_image_in_imgtag.php просмотрел и, не найдя ничего подозрительного (я их не изменял), пересохранил еще раз в UTF-8 и перезалил.
    Как ни странно все сразу заработало.
    Может кому пригодиться :)
     
  10. Offline

    Back Недавно здесь

    Регистрация:
    23.09.2010
    Сообщения:
    22
    Симпатии:
    5
    Пол:
    Мужской
    Посмотрел Ваш сайт.. Советую вам сделать нормальную картинку корзины, выровнять ее по центру. В категориях советую заменить дебильную кнопку купить на нормальную и убрать кнопки, которые остались от поля с количеством. Еще я бы убрал вообще кнопку кипить с самой категории. Чтобы купить можно было зайдя в карточку товара...
     
  11. Offline

    spontan Недавно здесь

    Регистрация:
    03.04.2008
    Сообщения:
    5
    Симпатии:
    0
    Пол:
    Мужской
    Вполне возможно, что нужно поправить некоторые строчки в файле
    administrator/components/com_virtuemart/viruemart.cfg.php
    а именно
    // these path and url definitions here are based on the Joomla! Configuration
    define( 'URL', 'http://localhost/' );
    define( 'SECUREURL', 'http://localhost/' );

    изменить на домен своего сайта
    не забываем в конце домена слеш / :D
     
  12. Offline

    Leokadio Недавно здесь

    Регистрация:
    19.05.2011
    Сообщения:
    1
    Симпатии:
    0
    Пол:
    Мужской
    А я что только не перепробовал, из-за не терпиливости...
    В итоге решил разобраться и открыл файл show_image_in_imgtag.php, а там значатся 2 файла влияющих на работу.
    Это: configuration.php - в корне файла и virtuemart.cfg.php
    Изменил кодировку - configuration.php с UTF-8 на ANSI и все мини картинки появились.;)

    Надеюсь и вам поможет
     
  13. draff
    Offline

    draff Russian Joomla! Team Команда форума

    Регистрация:
    17.01.2011
    Сообщения:
    6 036
    Симпатии:
    518
    Пол:
    Мужской
    Это чтобы все читающие твой ответ поломали/грохнули себе сайт?
     

Поделиться этой страницей

Загрузка...