Joomla 1.5 очередная проблема с кодировкой

Тема в разделе "Кодировки, ошибки отображения (крякозябры)", создана пользователем VrednyjKot, 11.12.2009.

  1. Offline

    VrednyjKot Недавно здесь

    Регистрация:
    11.12.2009
    Сообщения:
    1
    Симпатии:
    0
    Пол:
    Мужской
    Предыстория такая. Мне нужно было создать инет-магазин. Т.к.опыта нету, для экспериментов и обучения сделал сайт на orgfree.com
    Всё было нормально, разобрался...
    Делаю "чистовик". Выбрал на том же хостинге другой домен, orgfree показалось неблагозвучным:)
    Сделал сайт на freevar.com
    Установил джумлу, VirtueMart, русификаторы. Все как и в первый раз
    НО!!!!!!
    B всплыли проблемы с кодировкой в VirtueMart. Сам компонент работает как положено, админпанель русская. Но когда пытаюсь сохранить любые данные, русские символы в базу записываются как ????????
    Проблема кажется не в отображении, а в записи в базу - залез в PhpMyAdmin, там тоже ??????????
    Настройки MySQL идентичны в обоих случаях - проверил
    На первом сайте все нормально
    Кто может подсказать, в чем проблема?
     
    Последнее редактирование: 11.12.2009
  2.  
  3. Kadavr
    Offline

    Kadavr специалист

    Регистрация:
    18.10.2007
    Сообщения:
    557
    Симпатии:
    39
    Пол:
    Мужской
    Сделай дамп базы, можно просто текстовым файлом, сохрани где-нибудь на компе, удали старую базу. Создай новую с тем же названием, но в выпадающем списке 'Сравнение' выбери utf-8_general. Затем запросом восстанови все таблицы из дампа. Вообще-то должно помочь.
     

Поделиться этой страницей

Загрузка...