Joomla 1.5 Подскажите пожалуйста почему нет страницы о успешной регистрации

Тема в разделе "Создание структуры", создана пользователем witek661, 17.12.2009.

  1. Offline

    witek661 Недавно здесь

    Регистрация:
    11.08.2009
    Сообщения:
    41
    Симпатии:
    0
    Пол:
    Мужской
    Подскажите пожалуйста почему нет страницы о успешной регистрации(http://potolokideal.ru/.После регистрации пользователя выкидывает на главную страницу,в результате он не видит что регистрация прошла успешно и на его почту выслано письмо для авторизации на сайте.В настройках меню вроде всё выставил и текст описания написал но не работает[​IMG]
     
  2.  
  3. agruts
    Offline

    agruts Russian Joomla! Team

    Регистрация:
    01.03.2006
    Сообщения:
    612
    Симпатии:
    21
    Пол:
    Мужской
    смотреть логи, включить дебаг. проверит выполняется ли скрипт, который выводит сообщение о регистрации.

    кстати, а сама регистрация проходит успешно?
     
  4. Offline

    witek661 Недавно здесь

    Регистрация:
    11.08.2009
    Сообщения:
    41
    Симпатии:
    0
    Пол:
    Мужской
    регистрация проходит нормально,единственное что не так это то что после нажатие кнопки зарегистрироваться пользователя выкидывает на главную страницу без оповещения о том что регистрация прошла успешно.Если можно поконкретней что именно смотреть,что есть дебаг?
     
  5. Kadavr
    Offline

    Kadavr специалист

    Регистрация:
    18.10.2007
    Сообщения:
    557
    Симпатии:
    39
    Пол:
    Мужской
    В модуле регистрации, скорее всего, стоит опция - после регистрации отправить на главную страницу. Там обычно две строки - одна со страничкой куда отправить после регистрации (стоит, видимо, index.php), другая - куда после выхода. Попробуйте убрать все записи.
     
  6. agruts
    Offline

    agruts Russian Joomla! Team

    Регистрация:
    01.03.2006
    Сообщения:
    612
    Симпатии:
    21
    Пол:
    Мужской
    Kadavr, если судить по скриншоту, то у него так и есть - все поля пустые


    witek661, дебаг это отладка (debug). в файле .htaccess добавьте строчку в начале
    php_value error_reporting “E_ALL”

    у меня такое подозрение, что проблема в самом скрипте, надо смотреть тот кусок, где проверяются поля параметров (на скриншоте) и что куда передается.
    возможно, нужный кусок просто закомментирован.

    а в каком браузере все это? во всех?
     
  7. Offline

    witek661 Недавно здесь

    Регистрация:
    11.08.2009
    Сообщения:
    41
    Симпатии:
    0
    Пол:
    Мужской
    пробовал строку добавит в htasess строку
    ,причём в разных местах проблему не решило,проверял в Мозиле и в IE,там не работает но думаю что и в остальных браузерах тоже.+ещё одна проблемка нарисовалась включил кэширование и сжатие страниц в итоге через некоторое время при заходе на сайт не отображаются подменю в левом блоке меню,удаляю кэш всё нормально,но на следующий день таже байда.У меня выключены модули(Authentication - LDAP,Authentication - OpenID, Authentication - GMail)может ав этом проблема что не видит пользователь что регистрация прошла?
     
    Последнее редактирование: 18.12.2009
  8. agruts
    Offline

    agruts Russian Joomla! Team

    Регистрация:
    01.03.2006
    Сообщения:
    612
    Симпатии:
    21
    Пол:
    Мужской
    да эти модули ни при чем, во всяком случае они никак не влияют на отображение окна о регистрации.

    а на других компах пробовали? попросите когото из знакомых, друзей проверить.
     

Поделиться этой страницей

Загрузка...