Выдает ошибку при загрузке шаблона

Тема в разделе "Установка и обновление расширений Joomla", создана пользователем Antonha, 30.01.2010.

  1. Offline

    Antonha Недавно здесь

    Регистрация:
    30.01.2010
    Сообщения:
    5
    Симпатии:
    0
    Пол:
    Мужской
    Добрый день. При нажатии в панеле управления админа на расширение - шаблоны, выдает такую ошибку:

    Warning: TemplatesController::require_once(Z:\home\localhost\www\project_viam\administrator\components\com_templates\admin.templates.html.php) [function.TemplatesController-require-once]: failed to open stream: No such file or directory in Z:\home\localhost\www\project_viam\administrator\components\com_templates\controller.php on line 60

    Fatal error: TemplatesController::require_once() [function.require]: Failed opening required 'Z:\home\localhost\www\project_viam\administrator\components\com_templates\admin.templates.html.php' (include_path='.;/usr/local/php5/PEAR') in Z:\home\localhost\www\project_viam\administrator\components\com_templates\controller.php on line 60


    В линии 60 прописано require_once (JPATH_COMPONENT.DS.'admin.templates.html.php');

    Пробовал загрузить шаблон, не помогло. Что делать?
     
  2.  
  3. Offline

    ---_SkippeR_--- Недавно здесь

    Регистрация:
    13.11.2009
    Сообщения:
    181
    Симпатии:
    8
    Пол:
    Мужской
    перезалить пробовали?
     
  4. Offline

    Antonha Недавно здесь

    Регистрация:
    30.01.2010
    Сообщения:
    5
    Симпатии:
    0
    Пол:
    Мужской
    да пробовал. после первой установки стер даже денвер. установил все по новой, но ничего не изменилось.
     
  5. Dead Krolik
    Offline

    Dead Krolik специалист

    Регистрация:
    13.04.2007
    Сообщения:
    3 688
    Симпатии:
    101
    Пол:
    Мужской
    А какие файлы есть в директории \home\localhost\www\project_viam\administrator\ components\com_templates\
     
  6. Offline

    Antonha Недавно здесь

    Регистрация:
    30.01.2010
    Сообщения:
    5
    Симпатии:
    0
    Пол:
    Мужской
    1. папка helpers
    2. admin.templates.html.ph
    3. admin.templates.php
    4. controller.php
    5. index.html
    6. templates.xml
    7. toolbar.templates.html.php
    8. toolbar.templates.php
     
  7. Offline

    Antonha Недавно здесь

    Регистрация:
    30.01.2010
    Сообщения:
    5
    Симпатии:
    0
    Пол:
    Мужской
    народ, плиз, нужна помощь. не пойму в чем дело!!
     
  8. Emerit
    Offline

    Emerit Недавно здесь

    Регистрация:
    09.02.2008
    Сообщения:
    26
    Симпатии:
    1
    Пол:
    Мужской
    Также, имеется проблема.
    При нажатии через меню на Шаблоны (адрес: /administrator/index.php?option=com_templates) выдает пустую страницу, т.е. нельзя выбрать и настраивать шаблоны.
    При попытке загрузить шаблон (адрес: /administrator/index.php?option=com_installer) кидает на главную страницу и шаблон не устанавливает.
    При нажатии при загрузке шаблона на вкладку "Шаблоны" кидает на главную и выдает ошибку
    "500 - Произошла ошибка!
    View not found [name, type, prefix]: templates,,installerView"

    Пробовал поменять CHMOD на файлы и папки - не помогло.

    Пробовал
    файл administrator\components\com_content\controller.php
    Строчку
    Код
    if (!$filter_order) {
    $filter_order = 'section_name';
    }

    заменить на
    Код
    if (!$filter_order) {
    $filter_order = 'c.created DESC';

    Не помогло

    Пробовал проветь .htaccess - строки, указанные в паралельных темах (по поводу 500 - Произошла ошибка!) - строки заРЕМированы. Не помогло.

    Все аналогичные ссылки в меню (модули, компоненты и тп.) - работают.

    Исходные данные:
    - были поставлены демо данные. на другой сайт - нет - на обоих проблема.
    - Apache
    - PHP 5.2.12
    - Joomla! 1.5.15 Stable [ Wojmamni Ama Mamni ] 05-November-2009 04:00 GMT
    - браузер где наблюдается проблема - Firefox/3.5.6
    - кроме стандартного набора никаких дополнительных плагинов / модулей и других примочек установлено не было. Есть подозрения, что проблема в самом пакете, который скачал я и другие.

    Помогите пожалуйста - подскажите что сделать? что-то исправить или какую последнюю версию Joomla! заливать на хостинг? (тогда ссылку дайте, чтоли)
    Спасибо!
     
  9. Emerit
    Offline

    Emerit Недавно здесь

    Регистрация:
    09.02.2008
    Сообщения:
    26
    Симпатии:
    1
    Пол:
    Мужской
    Если я не ощибаюсь, была скачена отсюда: http://joom.ru/component/option,com_remository/Itemid,52/func,fileinfo/id,200/
     
  10. Offline

    Tael Недавно здесь

    Регистрация:
    03.02.2010
    Сообщения:
    2
    Симпатии:
    0
    Пол:
    Женский
    была такая же ошибка, изменила в файле controller.php все названия файла admin.templates.html.php на admin.templates.html.ph , вроде заработало
     
  11. Emerit
    Offline

    Emerit Недавно здесь

    Регистрация:
    09.02.2008
    Сообщения:
    26
    Симпатии:
    1
    Пол:
    Мужской
    не нашел такой строки в таком файле :(
    ,,,/administrator/components/com_content/controller.php
     
  12. Offline

    Tael Недавно здесь

    Регистрация:
    03.02.2010
    Сообщения:
    2
    Симпатии:
    0
    Пол:
    Женский
    это был ответ на первый вопрос в теме ) а вообще переустановила версию скачаную отсюда http://www.joomla.org/download.html
     
  13. Offline

    Antonha Недавно здесь

    Регистрация:
    30.01.2010
    Сообщения:
    5
    Симпатии:
    0
    Пол:
    Мужской
    Tael склоняю перед тобой голову. уже нескольео дней мучаюсь. большой прбольшой сэнкс[!]
     

Поделиться этой страницей

Загрузка...