Пропадают картинки в статье

Тема в разделе "Ошибки при работе с Joomla", создана пользователем froststorm, 23.02.2010.

  1. Offline

    froststorm Недавно здесь

    Регистрация:
    23.02.2010
    Сообщения:
    9
    Симпатии:
    0
    Пол:
    Мужской
    Пропадают картинки в статье, если статью разделяю "читать дальше" то при полном открытии картинки не отображаются, что это и как победить ?
     
  2.  
  3. Fanamura
    Offline

    Fanamura Доброта

    Регистрация:
    12.03.2007
    Сообщения:
    5 108
    Симпатии:
    159
    Пол:
    Мужской
    froststorm, мало информации. Какой путь у картинки, которая не отображается? Что в нем лишнее? Установлена ли SEF, какая Джумла? Когда Вы будете читать правила этого форума?
     
  4. Offline

    froststorm Недавно здесь

    Регистрация:
    23.02.2010
    Сообщения:
    9
    Симпатии:
    0
    Пол:
    Мужской
    О! спасибо вы натолкнули меня на идею , видимо при открытии полностью статьи путь должен быть дефолтный на папку stories, а у меня они в подпапке stories/articles/.. и видимо в этот момент что-то происходит. Спасибо сейчас буду разбираться. Joomla 1.5.14 / Что такое SEF ?
     
    Последнее редактирование: 23.02.2010
  5. Offline

    froststorm Недавно здесь

    Регистрация:
    23.02.2010
    Сообщения:
    9
    Симпатии:
    0
    Пол:
    Мужской
    Первую часть ошибки я понял , получаеться при нажатии "Прочесть полностью" Joomla отображает только ту часть которая была после "линии отреза", а первую часть почему- то не отображает.
    Такая ситуация со всеми статьями не только с какой-то одной.
     
  6. Fanamura
    Offline

    Fanamura Доброта

    Регистрация:
    12.03.2007
    Сообщения:
    5 108
    Симпатии:
    159
    Пол:
    Мужской
    Последнее редактирование модератором: 31.03.2014
  7. Offline

    froststorm Недавно здесь

    Регистрация:
    23.02.2010
    Сообщения:
    9
    Симпатии:
    0
    Пол:
    Мужской
    Нет не похоже , суть в том что ошибки нет по сути , просто после нажатия на "читать далее" , вы водиться только та часть статьи которая обрезана , а та часть что отображалась в списке статей остаеться как бы за бортом, теперь я уже понял что проблема не в отображении картинок а в отображении статьи
     
  8. Fanamura
    Offline

    Fanamura Доброта

    Регистрация:
    12.03.2007
    Сообщения:
    5 108
    Симпатии:
    159
    Пол:
    Мужской
    froststorm, ссылку на сайт дайте сюда
     
  9. Offline

    froststorm Недавно здесь

    Регистрация:
    23.02.2010
    Сообщения:
    9
    Симпатии:
    0
    Пол:
    Мужской
    Ссылку,не могу, он локально лежит. Работает на Denwerе. Я подумал может кто сталкивался ? Добавлены компоненты: !JoomlaComment, Quick FAQ, Xmap. Может быть такое что из-за какого то компонента такое возникает ?

    Только что поотключал компоненты , ничего не изменилось. Еще одна странность , при выключении плагина "Разрыв страницы в статьях" в редакторе статей и на сайте ничего не меняеться ...
     
    Последнее редактирование: 23.02.2010
  10. Offline

    froststorm Недавно здесь

    Регистрация:
    23.02.2010
    Сообщения:
    9
    Симпатии:
    0
    Пол:
    Мужской
    Ни у кого такого не было ? Никто не сталкивался ? Я начинающий потому сам победить не могу , просто нет идей как с этим бороться.
     
  11. Fanamura
    Offline

    Fanamura Доброта

    Регистрация:
    12.03.2007
    Сообщения:
    5 108
    Симпатии:
    159
    Пол:
    Мужской
    froststorm, разрыв страницы это не кнопка "подробнее".

    Еще раз.
    Скопируйте адрес картинки с главной, где она отображается.
    Затем скопируйте адрес этой же картинки, где она не отображается.
    Все вставьте сюда
     
  12. Offline

    froststorm Недавно здесь

    Регистрация:
    23.02.2010
    Сообщения:
    9
    Симпатии:
    0
    Пол:
    Мужской
    Там где отображается , в одном из пунктов меню :
    "http://localhost/newsportal/index.php?option=com_content&view=category&layout=blog&id=4&Itemid=5"
    Там где уже не отображается с обрезанием по линии "Читать полностью"
    "http://localhost/newsportal/index.php?option=com_content&view=article&id=13:2010-02-18-14-40-46&catid=4:2010-02-18-01-16-57&Itemid=5"
     
  13. Fanamura
    Offline

    Fanamura Доброта

    Регистрация:
    12.03.2007
    Сообщения:
    5 108
    Симпатии:
    159
    Пол:
    Мужской
    froststorm, понятно. Просто для теста любой другой шаблон ставили?
     
  14. Offline

    froststorm Недавно здесь

    Регистрация:
    23.02.2010
    Сообщения:
    9
    Симпатии:
    0
    Пол:
    Мужской
    Попробовал, первый попавшийся шаблон , потом второй, та же ситуация .
     
  15. Offline

    froststorm Недавно здесь

    Регистрация:
    23.02.2010
    Сообщения:
    9
    Симпатии:
    0
    Пол:
    Мужской
    Я нашел почему такое происходит. на одном форуме подобное же : Пропадает вводный текст
    "If your article has the option Intro Text set to Hide, when displayed on the main blog page the Read More link will disappear. Therefore, make sure the Intro Text is set to Show. Don't activate the Title Linkable option -- it causes a host of other problems.."
     

Поделиться этой страницей

Загрузка...