Знаки ??? вместо русских букв. При выборки с БД нормально, а напрямую появляются вопросы.

Тема в разделе "Кодировки, ошибки отображения (крякозябры)", создана пользователем Kacer, 28.02.2010.

  1. Kacer
    Offline

    Kacer Недавно здесь

    Регистрация:
    28.02.2010
    Сообщения:
    16
    Симпатии:
    0
    Пол:
    Мужской
    Проблема в следующем: имеем такой код в компоненте:
    Код (PHP):
    1. <?php print("цена: $row->cena руб.");?>

    При отображении на сайте русские буквы из базы данных отображаются нормально, а слова "цена" и "руб" знаками вопроса. Читал FAQ, но не понял что делать в моем случае.
     
  2.  
  3. Dead Krolik
    Offline

    Dead Krolik специалист

    Регистрация:
    13.04.2007
    Сообщения:
    3 688
    Симпатии:
    101
    Пол:
    Мужской
  4. Kacer
    Offline

    Kacer Недавно здесь

    Регистрация:
    28.02.2010
    Сообщения:
    16
    Симпатии:
    0
    Пол:
    Мужской
    Мне надо распечатать данные об автомобиле, которые берутся из базы данных. Например, марку авто.
    Беру следующий код:
    Код (PHP):
    1. <?php print("марка: $row->marka.");?>

    Здесь $row->marka берется из базы данных, например, примет значение "Рено". При этом на сайте отображается следующее: ?????: Рено.
     
  5. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Ну сохрани файл в UTF-8
     
  6. Kacer
    Offline

    Kacer Недавно здесь

    Регистрация:
    28.02.2010
    Сообщения:
    16
    Симпатии:
    0
    Пол:
    Мужской
    Спасибо.
     
    Последнее редактирование модератором: 05.04.2014
  7. Offline

    aLiGaR Недавно здесь

    Регистрация:
    16.10.2007
    Сообщения:
    23
    Симпатии:
    0
    Пол:
    Мужской
    Приветствую!
    Случилась подобная проблема, причем сама собой.
    Следовал принципу: работает - не трогай.
    Сайт не редактировался непосредственно до возникновения проблемы с кодировкой.
    В phpmyadmin база отображается нормально (сравнение utf8_unicode_ci).
    Другая база с ipb форумом (отдельный, не интегрированный) также работает нормально, форум показывает все верно.
    [​IMG]
    Joomla 1.0.15
     

Поделиться этой страницей

Загрузка...