Не устанавливается созданный мной шаблон

Тема в разделе "Внешний вид, шаблоны, графика", создана пользователем libero, 01.11.2007.

  1. Offline

    libero Недавно здесь

    Регистрация:
    01.11.2007
    Сообщения:
    15
    Симпатии:
    0
    При установке шаблона пишет: "Файл z:\home\localhost\www\templates\new_template\ уже существует - Вы пытаетесь дважды установить одно и то же расширение?"

    Нашёл несколько схожих тем: везде пишут про права, но у меня они настроены правильно (755 для всех новых папок и файлов), и нужные папки доступны для записи (joomla установлена на denwer на windows xp).

    ПС при этом в папке localhost\www\templates\new_template\ появляется файл index.php

    ППС шаблон верстал по инструкции, все соблюдено (перепроверял)

    Огромная просьба помочь... заранее спасибо
     
  2.  
  3. Jkr
    Offline

    Jkr Russian Joomla! Team

    Регистрация:
    04.08.2006
    Сообщения:
    465
    Симпатии:
    27
    Пол:
    Мужской
    Ответ: Не устанавливается созданный мной шаблон

    надо уделить папку new_template в папке templates перд тем как ставить новый шаблон.
     
  4. Offline

    libero Недавно здесь

    Регистрация:
    01.11.2007
    Сообщения:
    15
    Симпатии:
    0
    Ответ: Не устанавливается созданный мной шаблон

    ну конечно же я это сделал) в том числе я удалял полностью denwer и соответственно joomla и на чистые системы пытался установить, результат в общем-то тот же

    есть ещё варианты?
     
  5. GDie
    Offline

    GDie Недавно здесь

    Регистрация:
    02.01.2007
    Сообщения:
    184
    Симпатии:
    0
    Пол:
    Мужской
    Ответ: Не устанавливается созданный мной шаблон

    есть. посмотри внимательно template.xml и поменяй там название шаблона.
    или просто распакуй его в папку /template/, а не устанавливай.

    Добавлено через 24 секунды
    а еще у тебя запись о шаблоне в БД могла остаться
     
    Последнее редактирование: 02.11.2007
  6. Offline

    libero Недавно здесь

    Регистрация:
    01.11.2007
    Сообщения:
    15
    Симпатии:
    0
    Ответ: Не устанавливается созданный мной шаблон

    Дело в том, что я полностью удалял denwer с диска и устанавливал заново, поэтому не могла остаться папка, также при установке joomla в очередной раз, я удалял все таблицы

    проблема решилась следующим образом: добавил в папку images 1 изображение (до этого не было, шаблон был чист, только таблицы) и прописал его в xml, все установилось

    всем спасибо
     
  7. GDie
    Offline

    GDie Недавно здесь

    Регистрация:
    02.01.2007
    Сообщения:
    184
    Симпатии:
    0
    Пол:
    Мужской
    Ответ: Не устанавливается созданный мной шаблон

    Вот это часто помогает:
    XML Template Generator RE
    http://joom.ru/component/option,com_remository/Itemid,52/func,fileinfo/id,80/
     

Поделиться этой страницей

Загрузка...