Не запускается joomla сайт на хостинге

Тема в разделе "Перенос Joomla на хостинг и проблемы с хостингом", создана пользователем hoid, 12.05.2010.

  1. Offline

    hoid Недавно здесь

    Регистрация:
    12.05.2010
    Сообщения:
    4
    Симпатии:
    0
    Пол:
    Мужской
    ПОсле установки joomla 1.5.9 на сервер и установки базы MySQL при запуске сайта выдается ошибка

    Fatal error: Call to a member function on a non-object in /pub/home/grigab28/saxovat/administrator/components/com_sh404sef/sh404sef.class.php on line 2200

    а потом после нажатия F5 выдает пустую страницу.

    Тестировалось все на Денвере с PHP/5.2.4, а на хостинге php 4. Сталкивался кто-либо с такой ошибкой? Спасибо.
     
  2.  
  3. Kadavr
    Offline

    Kadavr специалист

    Регистрация:
    18.10.2007
    Сообщения:
    557
    Симпатии:
    39
    Пол:
    Мужской
    А в админку заходит? Если нет, попробуйте на локальном выключить sh404sef и перезалить на хост. Вам же говорят, что проблема с ним. И любопытства ради глянуть, что там в 2200-й строке этого файла такое написано.
     
  4. Offline

    hoid Недавно здесь

    Регистрация:
    12.05.2010
    Сообщения:
    4
    Симпатии:
    0
    Пол:
    Мужской
    Строка 2200:
    $shTemp = explode( '-', $subElem->data());
     
  5. Offline

    hoid Недавно здесь

    Регистрация:
    12.05.2010
    Сообщения:
    4
    Симпатии:
    0
    Пол:
    Мужской
    Что за компонента sh404sef?
     
  6. Kadavr
    Offline

    Kadavr специалист

    Регистрация:
    18.10.2007
    Сообщения:
    557
    Симпатии:
    39
    Пол:
    Мужской
    А вы что, даже не знаете, что это такое? А зачем ставили?
     
  7. Offline

    hoid Недавно здесь

    Регистрация:
    12.05.2010
    Сообщения:
    4
    Симпатии:
    0
    Пол:
    Мужской
    Нашел компоненту, раньше firebug ее загораживал. Снял все с публикации, перезалил базу данных. Пробовал удалять эту компоненту из папки components
    выдал
    Fatal error: onafterinitialise(): Failed opening required '/pub/home/grigab28/saxovat/administrator/components/com_sh404sef/sh404sef.class.php' (include_path='.:/usr/local/share/pear') in /pub/home/grigab28/saxovat/plugins/system/shsef.php on line 49
    удалил shsef.php
    в резулбтате показал сайт без фото в шапке
     

Поделиться этой страницей

Загрузка...