xml-rpc, metaweblog, newpost проблема

Тема в разделе "Программирование", создана пользователем login, 30.05.2010.

  1. Offline

    login Недавно здесь

    Регистрация:
    24.11.2009
    Сообщения:
    4
    Симпатии:
    0
    Пол:
    Мужской
    добрый вечер.
    не получается создать пост через xml-rpc.
    использую metaweblog.

    такой запрос:

    Код (PHP):
    1. include('IXR_Library.inc.php');
    2. $client = new IXR_Client('http://myjoomla/xmlrpc/index.php');
    3. if (!$client->query('metaWeblog.getPost', '1', 'admin', '12345')) {
    4.    die('Something went wrong - '.$client->getErrorCode().' : '.$client->getErrorMessage());
    5. }


    проходит на ура. возвращается содержимое поста

    Код (PHP):
    1. <?php
    2. include('IXR_Library.inc.php');
    3. $client = new IXR_Client('http://myjoomla/xmlrpc/index.php');
    4.  
    5. $content['title'] = 'deeeeeeeeeeeeesc';
    6. $content['description'] = 'deeeeeeeeeeeeesc';
    7.  
    8. if (!$client->query('metaWeblog.newPost', '666', 'admin', '12345', $content, true)) {
    9.     die('Something went wrong - '.$client->getErrorCode().' : '.$client->getErrorMessage());
    10. }
    11.  
    12. ?>


    возвращает
    Something went wrong - -32700 : parse error. not well formed

    подскажите, пожалуйста...
     
  2.  
  3. omfgpanda
    Offline

    omfgpanda специалист

    Регистрация:
    22.01.2008
    Сообщения:
    673
    Симпатии:
    53
    Пол:
    Мужской
    кодировка должна быть utf-8
     

Поделиться этой страницей

Загрузка...