Проблема с оформлением компонентов и модулей в шаблоне без оформления

Тема в разделе "Внешний вид, шаблоны, графика", создана пользователем Марк Королев, 15.06.2010.

  1. Марк Королев
    Offline

    Марк Королев Недавно здесь

    Регистрация:
    15.06.2010
    Сообщения:
    5
    Симпатии:
    0
    Пол:
    Мужской
    Здравствуйте!

    Создал пустой шаблон без оформления, в template.css описано лишь характеристики div-овых блоков.
    Сам шаблон состоит из файлов -
    css/template.css
    templateDetails.xml
    index.php

    С оформлением стандартных модулей и компонентов понятно, они выводятся без оформления. Но довольно таки странно и непонятно для меня следующее: есть компоненты, у которых свои стили оформления и, соответственно, свои файлы с таблицами стилей, но они так же выводятся без оного. А в PhocaGallery не подгружаются и скрипты к тому же.
    Уважаемые, подскажите, как решить эту проблему, почему такие компоненты как, допустим, Kunena, JEvents, да и все др. не подгружают свои файлы оформления и скрипты? Не прописывать же их всех в index.php шаблона?
     
  2.  
  3. Offline

    botanist специалист

    Регистрация:
    15.02.2009
    Сообщения:
    461
    Симпатии:
    49
    Пол:
    Мужской
    Ну добавь после <head>
    <jdoc:include type="head" />
     
    Марк Королев нравится это.
  4. Марк Королев
    Offline

    Марк Королев Недавно здесь

    Регистрация:
    15.06.2010
    Сообщения:
    5
    Симпатии:
    0
    Пол:
    Мужской
    Спасибо! Помогло!
     

Поделиться этой страницей

Загрузка...