Ошибка при установке Joomla: Warning: Parameter 1 to modMainMenuHelper::buildXML()

Тема в разделе "Установка и обновление Joomla!", создана пользователем fonarik, 11.09.2010.

  1. Offline

    fonarik Недавно здесь

    Регистрация:
    11.09.2010
    Сообщения:
    1
    Симпатии:
    0
    Пол:
    Мужской
    после установки жумлы версии 1.5.12 на сервер выбиваеться ошибка : Warning: Parameter 1 to modMainMenuHelper::buildXML() expected to be a reference, value given in V: \home\localhost\www\мой сайт\libraries\joomla\cache\handler\callback.php on line 99 и в админке тоже много ошибок:'(:'(:'(
     
    Последнее редактирование модератором: 11.09.2010
  2.  
  3. Лат
    Offline

    Лат Звоните 8 (905) 778-52-44

    Регистрация:
    31.01.2007
    Сообщения:
    1 751
    Симпатии:
    113
    Пол:
    Мужской
    1) Прочтите правила. Заголовок надо информативным делать. Я поправил, но в следующий раз будет бан.
    2) Ставьте 1.5.20
    3) На какой сервер ставите? Побольше подробностей
     
  4. Offline

    n010484 Недавно здесь

    Регистрация:
    02.01.2011
    Сообщения:
    16
    Симпатии:
    0
    Пол:
    Женский
    У меня на сайте образовалась такая же ошибка, как исправить? подскажите!
     
  5. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Вопросы те же
     
  6. Offline

    n010484 Недавно здесь

    Регистрация:
    02.01.2011
    Сообщения:
    16
    Симпатии:
    0
    Пол:
    Женский
    сервер agava
     
  7. Offline

    n010484 Недавно здесь

    Регистрация:
    02.01.2011
    Сообщения:
    16
    Симпатии:
    0
    Пол:
    Женский
    ошибка в самом сайте /libraries/joomla/cache/handler/callback.php on line 99
    ошибки в админ-панели :
    /libraries/joomla/cache/cache.php on line 143
    /libraries/joomla/session/session.php on line 283
    administrator/components/com_datsogallery/admin.datsogallery.php on line 2646
    /administrator/components/com_admin/tmpl/sysinfo_config.php on line 35, on line 37, on line 39, on line 41, и др. строчки (оч.много)
    самое основное - это /libraries/joomla/cache/handler/callback.php on line 99? т.к. это "болтается" на сайте:(
     
  8. Offline

    n010484 Недавно здесь

    Регистрация:
    02.01.2011
    Сообщения:
    16
    Симпатии:
    0
    Пол:
    Женский
    Для чего спрашивалось??? кто-нибудь подскажите.... как решить данную проблему... пожалллуйста....... :(
     
  9. Offline

    n010484 Недавно здесь

    Регистрация:
    02.01.2011
    Сообщения:
    16
    Симпатии:
    0
    Пол:
    Женский
    Ошибки все исправлены! Причина была в неправильной версии php. у меня стояла на хостинге php 5.3.х, поменяла на php 4..... и ни одной ошибки нет! так что внимательнее с сопоставлением версий!
     
  10. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    n010484, для джумлы 1.5 лучше PHP 5.2
     
  11. Offline

    _voland_ специалист

    Регистрация:
    12.04.2008
    Сообщения:
    2 173
    Симпатии:
    102
    Пол:
    Мужской
    И сам движок с версии 1,5,15 совместим с 5,3 - вот к каким бессмысленным темам приводит неуказание версий
     
  12. Offline

    snow_irbis Недавно здесь

    Регистрация:
    21.11.2012
    Сообщения:
    1
    Симпатии:
    0
    Пол:
    Мужской
    Находим файл modules/mod_mainmenu/helper.php
    Заменяем строчку

    function buildXML(&$params)

    на

    function buildXML($params)

    Всё. Есть меню.

    С ошибками в админке нужно возиться отдельно и долго, лучше обновиться до свежей версии.
     

Поделиться этой страницей

Загрузка...