Не работают ссылки!

Тема в разделе "Ошибки при работе с Joomla", создана пользователем Денис Иванов, 27.11.2010.

  1. Offline

    Денис Иванов Недавно здесь

    Регистрация:
    27.11.2010
    Сообщения:
    1
    Симпатии:
    0
    Пол:
    Мужской
    Работает только главная страница,а если создаю новую страницу пишет ошибку

    Not Found
    The requested URL /osaite.html was not found on this server.

    Подсказка Денвера

    Вы ошиблись при наборе URL в браузере. Вероятнее всего, сервер пытается найти файл Z:/home/gm/www/osaite.html, которого не существует.

    В случае использования CGI-скриптов, корректные пути к CGI-директориям следующие:

    HELLLPPP!!!!!:'(
     
  2.  
  3. Offline

    r-style Недавно здесь

    Регистрация:
    11.02.2013
    Сообщения:
    39
    Симпатии:
    1
    Пол:
    Мужской
    У меня такаяже беда!!! Но тока на Appserv. Тоже открыта тема на этом форуме. Но результата никакого.
     
  4. Offline

    r-style Недавно здесь

    Регистрация:
    11.02.2013
    Сообщения:
    39
    Симпатии:
    1
    Пол:
    Мужской
    Итааак , я чтото уже накопал:
    В админке переходим на вкладку Сайт, там в правом углу выключаем параметр Включить SEF (ЧПУ)

    В результате ссылки работают, но в строке адреса почемуто при переключении ссылок не меняется их адрес?!?! вот это вопросик?=O
     
  5. Offline

    r-style Недавно здесь

    Регистрация:
    11.02.2013
    Сообщения:
    39
    Симпатии:
    1
    Пол:
    Мужской
    Решил проблему!
    Денис, вообщен надо играть с Настройки SEO (Админка->Общие настройки->Сайт)
    Там есть первых два параметра.
    Поиграй с ними. И всё получится.
     
  6. shurikkan
    Offline

    shurikkan Russian Joomla! Team Команда форума

    Регистрация:
    01.09.2011
    Сообщения:
    1 856
    Симпатии:
    162
    Пол:
    Мужской
    На всякий случай напомню: если в блоке настроек "Настройки SEO" (Сайт -> Общие настройки -> Сайт) в параметре "Перенаправление URL" селектор стоит в положении "Да", то не забываем переименовать файл htaccess.txt в корневой директории сайта в .htaccess. Иначе навигация по меню работать не будет.
     
  7. Offline

    r-style Недавно здесь

    Регистрация:
    11.02.2013
    Сообщения:
    39
    Симпатии:
    1
    Пол:
    Мужской
    Ну да, это и написано в примечании админки на вкладке сайт в общих настройка)
     
  8. Offline

    zamez Недавно здесь

    Регистрация:
    24.03.2013
    Сообщения:
    1
    Симпатии:
    0
    Пол:
    Мужской
    у меня похожая проблема
    шаблон SJ_company
    перестали работать ссылки на материалах Категориях "Slide Show", не могу разобраться в чём дело
    когда к слайдшоу привязываешь другую категорию материалов - всё работает отлично
    когда создаёшь новый материал категории "Slide Show" - ничего не работает
     

Поделиться этой страницей

Загрузка...