Мистика с урлами Virtuemart, одна сборка разные ответы сервера

Тема в разделе "Ошибки при работе с Joomla", создана пользователем rockethe, 11.04.2011.

  1. Offline

    rockethe Недавно здесь

    Регистрация:
    13.11.2009
    Сообщения:
    31
    Симпатии:
    0
    Пол:
    Мужской
    Поставил одну сборку (файлы и база) на два домена, настроил, запустил.

    Урл страницы товара выглядит так:
    index.php?page=shop.browse&category_id=3&option=com_virtuemart&Itemid=55

    И тут мистка, по первому сайту ответ сервера
    index.php?page=shop.browse&category_id=3&option=com_virtuemart&Itemid=55
    Status: HTTP/1.1 301 Moved Permanently
    на страницу
    index.php?page=shop.browse&category_id=3&option=com_virtuemart&Itemid=55&vmcchk=1&Itemid=55


    по другому сайту все в порядке,
    index.php?page=shop.browse&category_id=3&option=com_virtuemart&Itemid=55
    выдает
    Status: HTTP/1.1 200 OK


    Оба сайта на одном акке, cpanel
    у обоих одинаковые htaccess robots.txt
    вся файловая структура Джумлы и всех компонентов одинакова,
    импортирована ОДНА база, без изменений,

    Что это может быть? Ломаю голову не понимаю откуда разница в урлах.
     
  2.  
  3. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Это влияет проверка включения cookies. Можно выключить на другом сайте проверку cookies в Virtuemart.
    Возможно на другом сайте проблемы с записью сессий.

    А вообще, рекомендую использовать sh404sef для VM, тем более, что там сейчас реализованы канонические ссылки.
     

Поделиться этой страницей

Загрузка...