Некорректная установка плагина - кирдык всему

Тема в разделе "Установка и обновление расширений Joomla", создана пользователем Asho, 08.06.2011.

  1. Offline

    Asho Недавно здесь

    Регистрация:
    08.06.2011
    Сообщения:
    6
    Симпатии:
    0
    Пол:
    Мужской
    Всем привет.
    Помогите, пожалуйста, с такой штукой: я по дури установил плагин в джумлу 1.6, не закинув его предварительно на хостинг (дэнвер). Теперь у меня при попытке войти в любой материал появляется сообщение
    Fatal error: Call to a member function registerEvent() on a non-object in Z:....on line 5
    При этом админка работает, но сделать внутри нее с плагином (отключить, например) хоть что-то не получается - вылазит такое же сообщение.
    В общем, как это победить, подскажите, пожалуйста.
     
  2.  
  3. Offline

    mailmoney Пользователь

    Регистрация:
    14.01.2009
    Сообщения:
    241
    Симпатии:
    19
    Пол:
    Мужской
    Зайди в phpmyadmin там таблица jos_plugins. В ней поле published - вот отключи в 0 его для своего плагина
     
  4. Offline

    Asho Недавно здесь

    Регистрация:
    08.06.2011
    Сообщения:
    6
    Симпатии:
    0
    Пол:
    Мужской
    спасибо, но вылезала та же ошибка.
    короче я переустановил папку с плагинами, и все заработало нормально.
    однако этот новый плагин виден в таблице дополнений, но, вроде, не мешает.
     
  5. Offline

    bugmenot специалист

    Регистрация:
    15.03.2009
    Сообщения:
    647
    Симпатии:
    39
    Пол:
    Мужской
    Все расширения (и плагины, и модули, и компоненты) находятся в jos_extensions. Вот там и нужно удалить информацию о плагине.

    Таким образом джумла про него вовсе забудет, а не просто будет считать выключенным, словно ты выключал через админку.
     

Поделиться этой страницей

Загрузка...