Проблема с установкой компонентов - загрузка неудачна

Тема в разделе "Кодировки, ошибки отображения (крякозябры)", создана пользователем triumph, 06.01.2008.

  1. Offline

    triumph Недавно здесь

    Регистрация:
    06.01.2008
    Сообщения:
    3
    Симпатии:
    0
    Выдает ошибку после установки компонента. Пишит что, Загрузка component - загрузка неудачна, ОШИБКА: В установочном пакете невозможно найти XML-файл установки. и Загрузка component - неудачна Установочный файл не найден:/var/www/vhosts/mysite.ru/httpdocs/media/install_477febe6c7481/. :( Думаю с компонентом все нормально, потому что на другом сайте я попробовал установить это компонент и получился. Ну там другой хостинг. Но в чем проблема не знаю, пожалуйста, помогите решить эту проблему.

    media/ Доступен для записи
    administrator/components/ Доступен для записи
    components/ Доступен для записи
    images/stories/ Доступен для записи
     
  2.  
  3. chilly_bang
    Offline

    chilly_bang специалист

    Регистрация:
    30.04.2006
    Сообщения:
    1 545
    Симпатии:
    38
    Пол:
    Мужской
    Ответ: Проблема с установкой компонентов - загрузка неудачна

    может в хостинге проблема?
     
  4. agruts
    Offline

    agruts Russian Joomla! Team

    Регистрация:
    01.03.2006
    Сообщения:
    612
    Симпатии:
    21
    Пол:
    Мужской
    Ответ: Проблема с установкой компонентов - загрузка неудачна

    именно с этого архива на другом хосте устанавливалось или этот же компонент, но из другого архива?
    дело в том, что компоненты очень часто запаковывают вместе с модулями, либо файлом ридми. Поэтому, надо распаковать, и там будет архив с самим компонентом, возможно архивы модулей или ридми. Инсталлятор не может найти ХМЛ, потому что при установке, раcпаковывая архив, он не видит этого файла, потому что он скорее всего во вложенном архиве, в котором сам компонент и находится.
    Очень распространенная ситуация.

    Если это не так, то надо проверить, все ли компоненты не устанавливаются или только этот. Если все без исключения, тогда пинать саппорт хостера либо перейти к другому.

    ps. Указывайте сразу хостинг, на котором проблема встречается, это облегчит решение вопроса, т.к. кто-то может уже с этим хостингом сталкивался...
     
  5. Gammy
    Offline

    Gammy Недавно здесь

    Регистрация:
    27.08.2007
    Сообщения:
    25
    Симпатии:
    1
    Пол:
    Мужской
    Ответ: Проблема с установкой компонентов - загрузка неудачна

    Я уже где-то на форуме описывал подобную ситуацию....
    Варианты могут быть следующие:
    1. Хостер включил режим Safe Mode. И не желает его выключать (пример - jino.ru)
    Решение: У того же хостера описано как это дело обойти, например, эмулирую PHP с помощью CGI.
    Еще решение: Установить все компоненты на локале, а потом, используя дамп базы - перенести все на хостинг.

    2. Самый простой вариант: Распаковать архив с компонентом, скопировать папку с распакованным архивом в папку media, и попробовать установить компонент уже из media. Кстати, тут же появляется возможность поиграться с XML - файлом. Правда, против Safe Mode данное решение не сработает.
    Удачи!
     
  6. Offline

    triumph Недавно здесь

    Регистрация:
    06.01.2008
    Сообщения:
    3
    Симпатии:
    0
    Ответ: Проблема с установкой компонентов - загрузка неудачна

    Да, именно с этого архива на другом хосте устанавливалось.

    Добавлено через 47 минут
    Распаковал архив с компонентом, скопировал папку с распакованным архивом в папку media, и попробовал установить компонент уже из media. Пишет что, "component - завершилась ошибкой, Другой компонент уже использует каталог: "/var/www/vhosts/мойсайт.ru/httpdocs/components/com_virtuemart/". Проверил FTP, но там в папке components нет "com_virtuemart", что мне делать???

    Добавлено через 59 минут
    Кстати, я забил учитывать что на панели управления показывает "PHP magic_quotes_gpc установлено в `OFF` вместо `ON`" может проблема из-за этого ?
     
    Последнее редактирование: 08.01.2008
  7. Offline

    triumph Недавно здесь

    Регистрация:
    06.01.2008
    Сообщения:
    3
    Симпатии:
    0
    Ответ: Проблема с установкой компонентов - загрузка неудачна

    Спасибо, установил. Хостер отключил режим Safe Mode и получился.
     

Поделиться этой страницей

Загрузка...