Смена версии PHP на хостинге

Тема в разделе "Ошибки при работе с Joomla", создана пользователем bubanay, 26.07.2011.

  1. Offline

    bubanay Недавно здесь

    Регистрация:
    06.04.2011
    Сообщения:
    134
    Симпатии:
    0
    Пол:
    Мужской
    Похожая тема у вас тут есть но ответа я в ней не нашел. Сайт лежит на хостинге с версией PHP 4.4.9, там есть возможность сменить версию PHP на 5.1.6 и 5.2.10. при смене версии сайт пропадает и при переходе на него выдается ошибка
    Database Error: Unable to connect to the database:The MySQL adapter "mysql" is not available.

    Подскажите как мне исправить ошибку.
     
  2.  
  3. Offline

    bubanay Недавно здесь

    Регистрация:
    06.04.2011
    Сообщения:
    134
    Симпатии:
    0
    Пол:
    Мужской
    Тех поддержка ответила что нужно включить нужные модули
    [​IMG]
    Не вкурсе какие из этих модулей нужны для работы joomla?
     
  4. Offline

    bubanay Недавно здесь

    Регистрация:
    06.04.2011
    Сообщения:
    134
    Симпатии:
    0
    Пол:
    Мужской
    никто не в курсе?
     
  5. Tureckiy
    Offline

    Tureckiy специалист

    Регистрация:
    11.04.2009
    Сообщения:
    423
    Симпатии:
    30
    Пол:
    Мужской
    это подключение к базе не верное (хост, логин, имя базы, пароль)
     
  6. Offline

    bubanay Недавно здесь

    Регистрация:
    06.04.2011
    Сообщения:
    134
    Симпатии:
    0
    Пол:
    Мужской
    я посмотрел какие модули работают на PHP 4.4.9 и поставил такие же на версии 5.2.1. Проблема с БД исчезла, но появилась другая ошибка. Значит включил не все.
     
  7. Offline

    bubanay Недавно здесь

    Регистрация:
    06.04.2011
    Сообщения:
    134
    Симпатии:
    0
    Пол:
    Мужской
    перерыл весь интернет, нужно было включить модули ftp, gd, imagick, json, mysql, session, zlib, ctype. Может пригодиться кому нибудь.
     

Поделиться этой страницей

Загрузка...