Cборка PHP

Тема в разделе "Психологическая консультация", создана пользователем sergiks, 02.08.2011.

  1. sergiks
    Offline

    sergiks специалист

    Регистрация:
    10.10.2010
    Сообщения:
    362
    Симпатии:
    36
    Пол:
    Мужской
    Проект живет на хостинге nic.ru, все было супер до тех пор, пока не понадобился амазоновский AWS SDK.
    Этому перцу требуется Class 'SimpleXmlIterator' — который то ли из-за бага, то ли из-за неровно настроенного PHP на хосте, отсутствует. Это под php 5.2.10

    Поддержка рекомендует или откатиться на php 5.1 или собрать свой php.

    Вопрос: какие опции включать при ./configure, чтобы было "как раньше"?

    phpinfo() показывает следующее:
    Код (CODE):
    1. PHP Version 5.2.10
    2.  
    3. System  FreeBSD web70.nic.ru 8.1-RELEASE-p2 FreeBSD 8.1-RELEASE-p2 #9: Mon Jun 20 16:38:20 MSD 2011 root@web22.nic.ru:/usr/obj/usr/src/sys/HNIC-IBM pl#27 amd64
    4. Build Date  Aug 21 2009 12:11:15
    5. Configure Command   './configure' '--prefix=/opt/php' '--with-apxs=/opt/apache/bin/apxs' '--enable-sockets' '--without-pear' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--disable-all' '--with-pcre-regex' '--enable-libxml' '--enable-xml' '--enable-spl'
    6. Server API  Apache

    В инструкции по сборке рекомендуют другие:
    Код (CODE):
    1. ./configure –-prefix=/home/[login]/php5.2.6/
    2. –-with-zlib –-with-mhash=/home/[login]/mhash/ –-with-bz2 -–with-gd
    3. –-enable-mbstring –-with-t1lib -–with-apxs=/home/[login]/etc/apache/bin/apxs –-enable-module=so


    К тому же 5.2.6 немного устарела, стабильная сейчас из линейки 5.2: 5.2.17

    Нужна психологическая поддержка бывалого админа и php'вода.
     
  2.  

Поделиться этой страницей

Загрузка...