Теряются переменные в админке

Тема в разделе "Аудит", создана пользователем Noway, 11.01.2008.

  1. Offline

    Noway Недавно здесь

    Регистрация:
    26.11.2006
    Сообщения:
    2
    Симпатии:
    0
    Здравствуйте!

    Возникла проблема в своем компоненте, в админке теряются переменные, которые храняться в форме в виде:
    <input type="hidden" name="id" value="<?php echo $row->id; ?>" />

    Т.е они отсылаются, все ок, но потом в модуль они не приходят!

    Раньше все было ок, сейчас не понятно что произошло


    Заранее спасибо всем!
     
  2.  
  3. sectus
    Offline

    sectus специалист

    Регистрация:
    19.04.2006
    Сообщения:
    1 210
    Симпатии:
    46
    Пол:
    Мужской
    Ответ: Теряются переменные в админке

    Нужно смотреть... так сказать очень сложно. Но я полагаю, что все проходит по такой схеме:

    форма
    \
    страница(сюда передались)
    \
    страница2(а тут уже нет)

    да?
     
  4. Offline

    Noway Недавно здесь

    Регистрация:
    26.11.2006
    Сообщения:
    2
    Симпатии:
    0
    Ответ: Теряются переменные в админке

    Да! Именно по такому! я смотрел содержимое заголовков. Данные идут постом, потом джумля делает редирект и данных уже нет
     
  5. sectus
    Offline

    sectus специалист

    Регистрация:
    19.04.2006
    Сообщения:
    1 210
    Симпатии:
    46
    Пол:
    Мужской
    Ответ: Теряются переменные в админке

    Если компонент Ваш, то это не Джумла делает редирект...
    включие в ссылку, по которой идет редирект, Вашу переменную со значением
     

Поделиться этой страницей

Загрузка...