не могу войти в админку после переноса с домена на домен внутри одного хостинга

Тема в разделе "Перенос Joomla на хостинг и проблемы с хостингом", создана пользователем iglinatv, 04.05.2012.

  1. Offline

    iglinatv Недавно здесь

    Регистрация:
    04.05.2012
    Сообщения:
    4
    Симпатии:
    0
    Пол:
    Женский
    Перенесла сайт на новый домен (оба домена на одном и то же хостинге, методом копирования всех папок и файлов). Сам сайт заработал сразу же, но в админку теперь зайти не могу. Выдает ошибку:

    Warning: require(/home/non76/public_html/Адрес_сайта/administrator/modules/mod_login/mod_login.php) [function.require]: failed to open stream: Permission denied in /home/non76/public_html/Адрес_сайта/libraries/joomla/application/module/helper.php on line 169

    Fatal error: require() [function.require]: Failed opening required '/home/non76/public_html/Адрес_сайта/administrator/modules/mod_login/mod_login.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/non76/public_html/Адрес_сайта/libraries/joomla/application/module/helper.php on line 169


    исправила в двух строках адрес сайта в файле configuration.php - не помогло. Строка 169 в helper.php содержит require $path;


    Что еще надо подправить? Подскажите, пожалуйста.
     
  2.  
  3. draff
    Offline

    draff Russian Joomla! Team Команда форума

    Регистрация:
    17.01.2011
    Сообщения:
    6 037
    Симпатии:
    518
    Пол:
    Мужской
    А сам файл есть ? administrator/modules/mod_login/mod_login.php
     
  4. Offline

    iglinatv Недавно здесь

    Регистрация:
    04.05.2012
    Сообщения:
    4
    Симпатии:
    0
    Пол:
    Женский
    Уважаемый draff - спасибо за ваш ответ. К сожалению, уже поздно его увидела, когда сама доковыряла :)
    В общем, решение было такое: почему-то права на файл mod_login.php полностью обнулились, я их выставила на 755. Это вернуло окошко авторизации в админку, однако после логина выдавался белый экран. Посмотрела лог ошибок в файле error_log в папке administrator - увидела там аналогичную ошибку с правами для файла public_html/Адрес_сайта/administrator/modules/mod_status/tmpl/default.php. Тоже выставила 755 (не знаю правильно или нет, но они тоже полностью нулевые стояли). После этого админка благополучно загрузилась :)
     

Поделиться этой страницей

Загрузка...