Joomla 1.5 После переноса на хостинг сайт частично перестал работать

Тема в разделе "Перенос Joomla на хостинг и проблемы с хостингом", создана пользователем spynit, 22.07.2012.

  1. Offline

    spynit Пользователь

    Регистрация:
    22.07.2012
    Сообщения:
    31
    Симпатии:
    0
    Пол:
    Мужской
    Здравствуйте! Проблемка с сайтом.
    Сайт сделан на Joomla 1.5, на Denwer все работает идеально, но после переноса на хостинг, загружается только главная страница, при нажатии на любой из пунктов меню, шаблон не загружается, подгружаются пункты меню и модуль поиска, без интерфейса, а при нажатии на меню категории появляется ошибка 404 "Компонент не найден!". При попытки попасть в админ центр форма входа просто перезагружается, никак не реагирует на неправильный пароль. В корне сайта создался файл error_log и там:

    PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: Cannot send session cookie - headers already sent by (output started at /путь к сайту/configuration.php:1) in путь к сайту/libraries/joomla/session/session.php on line 423
    PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: Cannot send session cache limiter - headers already sent (output started at /путь к сайту/configuration.php:1) in /путь к сайту/libraries/joomla/session/session.php on line 423
    PHP Warning: Cannot modify header information - headers already sent by (output started at путь к сайту/configuration.php:1) in /путь к сайту/libraries/joomla/session/session.php on line 426

    В чем тут суть?
     
  2.  
  3. draff
    Offline

    draff Russian Joomla! Team Команда форума

    Регистрация:
    17.01.2011
    Сообщения:
    6 044
    Симпатии:
    519
    Пол:
    Мужской
    открыть index.php Joomla в редакторе Notepad++ и сохранить без BOM
    п.с.
    Еще посмотри пробелы/отступы перед началом пхп кода в index.php шаблона
     
    Последнее редактирование: 22.07.2012
  4. Offline

    spynit Пользователь

    Регистрация:
    22.07.2012
    Сообщения:
    31
    Симпатии:
    0
    Пол:
    Мужской
    draff Добрый день!
    index.php сохранил без BOM
    пробелов и отступов нет
    а проблема осталась..что еще может быть причиной?
     
  5. draff
    Offline

    draff Russian Joomla! Team Команда форума

    Регистрация:
    17.01.2011
    Сообщения:
    6 044
    Симпатии:
    519
    Пол:
    Мужской
    1 или 2? Каким клиентом переносил файлы? Может регистр символов изменились, etc
    Смотри логи хостинга.
     
    spynit нравится это.
  6. Offline

    spynit Пользователь

    Регистрация:
    22.07.2012
    Сообщения:
    31
    Симпатии:
    0
    Пол:
    Мужской
    1
    клиентом CuteFTP.
    это второй сайт на хосте, первый работает нормально,а второй нет..может это как-то связано?
     
  7. draff
    Offline

    draff Russian Joomla! Team Команда форума

    Регистрация:
    17.01.2011
    Сообщения:
    6 044
    Симпатии:
    519
    Пол:
    Мужской
    Так просмотри все три index.php ,сайта,шаблона,администратора.Может таблицу сессий нужно было очистить перед переносом.
    Смотри логи хостинга,а то так гадать о причинах можно долго.

    ну смотря как настроено на хостинге.два каталога для доменов/сайтов ?
     
  8. blikblik
    Offline

    blikblik Активист

    Регистрация:
    12.03.2011
    Сообщения:
    112
    Симпатии:
    29
    Пол:
    Женский
    spynit , сохраните файл configuration.php в кодировке UTF-8 без BOM
     
  9. Offline

    spynit Пользователь

    Регистрация:
    22.07.2012
    Сообщения:
    31
    Симпатии:
    0
    Пол:
    Мужской
    blikblik
    draff
    с помощью Notepad++ меняю кодировку в файле index.php на UTF-8 без BOM, сохраняю, закрываю. Патом открываю, а кодировка стоит ANSI. почему не применяется?
     
  10. Offline

    spynit Пользователь

    Регистрация:
    22.07.2012
    Сообщения:
    31
    Симпатии:
    0
    Пол:
    Мужской
    с кодировкой разобрался, файлы index.php и configuration.php в кодировке UTF-8 без BOM
    такой текст появляется после нажатия на меню категории

    404 - Компонент не найден!
    Вы не можете посетить эту страницу из-за:

    устаревшие закладки в избранном
    поисковый сервер имеет устаревшие данные сайта
    некорректный адрес
    Вы не имеете доступа к этой странице
    Запрашиваемый ресурс не найден.
    Произошла ошибка при обработке вашего запроса!
    Пожалуйста, выберите одну из следующих страниц:

    Главная страница
    Если у вас возникли сложности, пожалуйста, свяжитесь с администрацией этого сайта.

    Компонент не найден!
     
  11. draff
    Offline

    draff Russian Joomla! Team Команда форума

    Регистрация:
    17.01.2011
    Сообщения:
    6 044
    Симпатии:
    519
    Пол:
    Мужской
    Уточни- админка уже открывается,работает? Что по 404-включи .htaccess
     
  12. Offline

    spynit Пользователь

    Регистрация:
    22.07.2012
    Сообщения:
    31
    Симпатии:
    0
    Пол:
    Мужской
    draff, да, админка заработала уже, вошел в нее..
    это как?
     
  13. draff
    Offline

    draff Russian Joomla! Team Команда форума

    Регистрация:
    17.01.2011
    Сообщения:
    6 044
    Симпатии:
    519
    Пол:
    Мужской
    Если формат файла htaccess.txt то переименуй в .htaccess
     
  14. Offline

    spynit Пользователь

    Регистрация:
    22.07.2012
    Сообщения:
    31
    Симпатии:
    0
    Пол:
    Мужской
    draff большое вам спасибо за помошь!
    проблема решилась путем отключения ЧПУ
     
  15. Offline

    vtronza Недавно здесь

    Регистрация:
    24.07.2012
    Сообщения:
    1
    Симпатии:
    0
    Пол:
    Мужской
    После переноса на хостинг перестали работать меню
    Все что вы советовали я выполнил, не помогло!!
     
  16. DKraev
    Offline

    DKraev <i>(aka gft)</i>

    Регистрация:
    16.08.2008
    Сообщения:
    1 627
    Симпатии:
    216
    Пол:
    Мужской
    Перестали работать - это как? Не работают переходы, вообще меню не отображается или что? Адрес сайта какой?
     

Поделиться этой страницей

Загрузка...