После включения SEF и mod_rewrite работает только главная страница

Тема в разделе "Joomla и SEF (ЧПУ)", создана пользователем Pixe1, 23.08.2012.

  1. Offline

    Pixe1 Недавно здесь

    Регистрация:
    23.08.2012
    Сообщения:
    4
    Симпатии:
    0
    Пол:
    Мужской
    Честно говоря по своей проблеме даже незнаю как спрашивать поисковики, прошу помощи людей опытных. Итак..

    Напрягало меня наличие index.php в URLe, ну и решил врубить штатный SEF, делал все по пунктам т.к. с htaccess мало знаком.
    1) htaccess.txt -> .htaccess;
    2) mod_rewrite on
    3) SEF - on
    4) суффиксы - вкл.

    после этого не работала ни одна ссылка на сайте, только главная страница.. Немного поковыряв, решил выключить ЧПУ и пока отложить, но выключив легче не стало. Тыкая и наблюдая заметил такой момент.

    Если в меню добавляю пункт который ведет на блог категории, не важно стандартная или К2, и она пустая - открывается... Если в эту категорию засунуть хоть 1 материал видим "Удаленный сервер или файл не найден". Если ссылку сразу на этот или любой другой материал - "403"..

    Устал форумы читать, решил закинуть дефолтный htaccess.txt, выключить штатное SEF и поставить sh404SEF.. итог тот же самый =\ уже незнаю что и смотреть.. Кстати не важно включен ли штатный ЧПУ или нет, ссылки бросает на 403 в основном.. (эт еще до установки sh404SEF). Поделитесь опытом)

    Заранее благодарен)
     
  2.  
  3. draff
    Offline

    draff Russian Joomla! Team Команда форума

    Регистрация:
    17.01.2011
    Сообщения:
    6 040
    Симпатии:
    518
    Пол:
    Мужской
    выключи Off
     
  4. Offline

    Pixe1 Недавно здесь

    Регистрация:
    23.08.2012
    Сообщения:
    4
    Симпатии:
    0
    Пол:
    Мужской
    Как я и писал в 1ом посте, первым делом попробовал снова выключить Mod_rewrite, SEF и суффиксы, и заменить на старый htaccess.txt, не помогло..
     
  5. draff
    Offline

    draff Russian Joomla! Team Команда форума

    Регистрация:
    17.01.2011
    Сообщения:
    6 040
    Симпатии:
    518
    Пол:
    Мужской
  6. Offline

    Pixe1 Недавно здесь

    Регистрация:
    23.08.2012
    Сообщения:
    4
    Симпатии:
    0
    Пол:
    Мужской
    Так, сначала.

    sh404SEF - выкл
    SEF, mod_rewrite - выкл
    .htaccess меня на старый htaccess.txt
    чищу кэш, проверяю...

    меню блога категории (пустой), работает, ссылка вида /index.php?option=com_k2&view=itemlist&layout=category&task=category&id=2&Itemid=78 как и ожидаю вроде;
    меню блога категории не пустой, "Удаленный сервер или файл не найден", ссылка без SEF (/index.php?option=com_k2&view=itemlist&layout=category&task=category&id=3&Itemid=97)
    пункт меню на статью - 403

    htaccess.txt -> .htaccess
    SEF, mod_rewrite ON
    чищу кэш, смотрю..

    Все тоже самое, только ссылочки теперь по человечески выглядят - site/123.html, site/products.html
     
  7. draff
    Offline

    draff Russian Joomla! Team Команда форума

    Регистрация:
    17.01.2011
    Сообщения:
    6 040
    Симпатии:
    518
    Пол:
    Мужской
    ты сеф404 не просто выключай,а чисти кеш/purge,а еще лучше удали все ссылки созданные сеф404.

    не включая встроенный ЧПУ, создай категорию- статью-пункт меню на категорию
    а еще вариант- тренируйся на демо joomla.org
     
  8. Offline

    Pixe1 Недавно здесь

    Регистрация:
    23.08.2012
    Сообщения:
    4
    Симпатии:
    0
    Пол:
    Мужской
    совет думаю хороший, только поздно) сейчас озадачен тем чтоб восстановить то, что поколечил..

    а по моей проблеме, дело врядли в сеф404 т.к. ее я ставил в надежде что она поправит проблему, а получилось что итог один что с вкл сеф404, что со стандартным сеф...

    И я уже пробовал, все выключать, делать свежую категорию и статью в нее, и переназначать пункт меню.. не помогло, завтра продолжу эксперименты свои.. Спасибо за ответы
     

Поделиться этой страницей

Загрузка...