Странное поведение при использовании usemap

Тема в разделе "CSS, HTML, Web 2.0, верстка по web-стандартам", создана пользователем olga6, 17.10.2012.

  1. Offline

    olga6 Недавно здесь

    Регистрация:
    17.10.2012
    Сообщения:
    1
    Симпатии:
    0
    Пол:
    Женский
    Здравствуйте.

    На большом фото коллектива нужно сделать всплывающие подсказки при наведении курсора и переход по клику на страницу с данными о сотруднике.

    1) Сделала карту <usemap>
    2) Для каждого человека в теге <AREA> прописала всплывающую подсказку через стандартный плагин tooltip (moototools) и указала HREF страницу перехода.

    Все работает, но: Внизу, под рисунком появляется закрывающая скобка для каждого из тегов <AREA.....>.
    Убираю скобку из кода, - все нормально. Но это ведь неправильно!
    Подскажите, почему закрывающую угловую скобку Joomla считает за "лишнюю" ?


    Код:
    В первом <area> закрывающая угловая скобка не поставлена, отработает нормально.
    В последнем <area> закрывающая угловая скобка стоит и она появится на сайте, внизу под рисунком.

    <IMG SRC="/staff_org.gif" WIDTH=650 HEIGHT=970 BORDER=0 USEMAP="#staff_org.gif">

    <MAP NAME="staff_org.gif">

    <AREA SHAPE="RECT" COORDS="273,6,420,73"
    HREF="/link" ALT="FIO" TARGET="_self"
    {tooltip}Click for seeng more{end-title}Short description{end-texte}{end-tooltip}
    .......

    <AREA SHAPE="RECT" COORDS="273,6,420,73"
    HREF="/link" ALT="FIO" TARGET="_self"
    {tooltip}Click for seeng more{end-title}Short description{end-texte}{end-tooltip}>

    </map>
     
  2.  
  3. DKraev
    Offline

    DKraev <i>(aka gft)</i>

    Регистрация:
    16.08.2008
    Сообщения:
    1 627
    Симпатии:
    216
    Пол:
    Мужской
    Ну по всей видимости именно из-за плагина и считает лишней.
     

Поделиться этой страницей

Загрузка...