ARTIO Sef направляет на главную

Тема в разделе "Joomla и SEF (ЧПУ)", создана пользователем Vins9, 27.02.2008.

  1. Offline

    Vins9 Недавно здесь

    Регистрация:
    19.02.2008
    Сообщения:
    2
    Симпатии:
    0
    Суть такого, что когда вводишь http://site.ru/novosti/index.php (без www. ) То выдаёт ошибку 404, и по параметрам гонит на главную и делает следующее http://www.site.ru/index.php/index.php

    А вот уже когда http://www.site.ru/novosti/index.php то страница грузится нормально.

    Помогите пжл. как это можно исправить?
     
  2.  
  3. Fanamura
    Offline

    Fanamura Доброта

    Регистрация:
    12.03.2007
    Сообщения:
    5 108
    Симпатии:
    159
    Пол:
    Мужской
    Ответ: ARTIO Sef направляет на главную

    RewriteEngine On
    RewriteBase /
    RewriteCond %{HTTP_HOST} ^домен.ru$
    RewriteRule ^(.*)$ http://www.домен.ru/$1 [NC,R=301,L]
    RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR]
    RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$ [NC]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule (.*) index.php

    Допиши это в начало htaccess, если кто-нибудь введет адрес без www, то его автоматически переведет на "правильный" адрес, должно помочь
     
  4. Offline

    Vins9 Недавно здесь

    Регистрация:
    19.02.2008
    Сообщения:
    2
    Симпатии:
    0
    Ответ: ARTIO Sef направляет на главную

    Огромное спасибо, всё работает[!]
     

Поделиться этой страницей

Загрузка...