Внутри админки выдает 500

Тема в разделе "Сайт умер, лежит и не дышит", создана пользователем KolllaK, 06.04.2013.

  1. Offline

    KolllaK Недавно здесь

    Регистрация:
    12.08.2010
    Сообщения:
    14
    Симпатии:
    0
    Пол:
    Мужской
    Доброго времени суток.
    Излагаю ситуацию:
    С моего аккаунта у хостера начал лететь спам. Аккаунт был заблокирован хостером до решения проблем.
    Были изменены пароли, удалены "левые" эмейлы и спам прекратился.
    Хостер разблокировал аккаунт.
    После разблокировки 2 сайта работают и функционирую полностью нормально, а вот с третим проблемы :
    Сам сайт рабочий, все отображается как и было, зайти в админку можно, но:
    пользователи, менеджер материалов, компоненты, разделы меню - все что имеет "вес" - все выбивает 500 при заходе. Ничего нельзя отредактировать.
    .htaccess и configuration.php не менялись мной, поддержка хостера говорит что никаких изменений не было с их стороны.
    Надеюсь изложил в более-менее ясной форме, просьба не хаять, увы во всем этом я ноль. Буду рад хоть какой-то помощи с описанием как для новичков и чайников.
    Заранее благодарен,
    с ув. Сергей.
     
  2.  
  3. draff
    Offline

    draff Russian Joomla! Team Команда форума

    Регистрация:
    17.01.2011
    Сообщения:
    6 041
    Симпатии:
    518
    Пол:
    Мужской
    плагин авторизации включен ?
     
  4. Offline

    KolllaK Недавно здесь

    Регистрация:
    12.08.2010
    Сообщения:
    14
    Симпатии:
    0
    Пол:
    Мужской
    Извините за долгие ответы, но параллельно гуглил как и что проверять.

    User - Joomla! и Authentication - Joomla в таблице jos_plugins . `published` стоит "1"
     
  5. draff
    Offline

    draff Russian Joomla! Team Команда форума

    Регистрация:
    17.01.2011
    Сообщения:
    6 041
    Симпатии:
    518
    Пол:
    Мужской
    А что в логах хостинга /logs/error.log and access.log ?
     
  6. Offline

    KolllaK Недавно здесь

    Регистрация:
    12.08.2010
    Сообщения:
    14
    Симпатии:
    0
    Пол:
    Мужской
    На фтп в папке /logs/ только папка "str" в которой логами и не пахнет.
    Наверно это очень плохо..
     
  7. draff
    Offline

    draff Russian Joomla! Team Команда форума

    Регистрация:
    17.01.2011
    Сообщения:
    6 041
    Симпатии:
    518
    Пол:
    Мужской
    Это папка логов хостинга? Задай вопрос хостеру.
    Если в корне сайта- наверно шелл.
     
  8. Offline

    KolllaK Недавно здесь

    Регистрация:
    12.08.2010
    Сообщения:
    14
    Симпатии:
    0
    Пол:
    Мужской
    Это находится в public_html.
    Папки логов вообще не вижу( все по фтп облазил.
    Хостеру написал, но ответ получу не раньше середины завтрашнего дня.
     
  9. Offline

    KolllaK Недавно здесь

    Регистрация:
    12.08.2010
    Сообщения:
    14
    Симпатии:
    0
    Пол:
    Мужской
    Логи нашлись в панели управления хостингом.
    Есть варианты :
    Логи использования Apache
    Логи ошибок Apache

    Я дважды полазил по менеджеру материалов (он выдает 500), менеджеру разделов и менеджеру категорий (там ничего не создано, они доступны для создания).

    Первый лог (Логи использования Apache) :

    Код (CODE):
    1. *Мой айпи* - - [07/Apr/2013:19:38:13 +0300] "GET /administrator/index.php?option=com_content HTTP/1.0" 500 290 "*Мой сайт*/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0"
    2. *Мой айпи* - - [07/Apr/2013:19:38:14 +0300] "GET /administrator/index.php HTTP/1.0" 200 4919 "*Мой сайт*/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0"
    3. *Мой айпи* - - [07/Apr/2013:19:38:15 +0300] "GET /administrator/index.php?option=com_content HTTP/1.0" 500 290 "*Мой сайт*/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0"
    4. *Мой айпи* - - [07/Apr/2013:19:38:16 +0300] "GET /administrator/index.php HTTP/1.0" 200 4919 "*Мой сайт*/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0"
    5. *Мой айпи* - - [07/Apr/2013:19:38:20 +0300] "GET /administrator/index.php?option=com_sections&scope=content HTTP/1.0" 200 4773 "*Мой сайт*/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0"
    6. *Мой айпи* - - [07/Apr/2013:19:38:22 +0300] "GET /administrator/index.php HTTP/1.0" 200 4919 "*Мой сайт*/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0"
    7. *Мой айпи* - - [07/Apr/2013:19:38:24 +0300] "GET /administrator/index.php?option=com_sections&scope=content HTTP/1.0" 200 4773 "*Мой сайт*/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0"
    8. *Мой айпи* - - [07/Apr/2013:19:38:25 +0300] "GET /administrator/index.php HTTP/1.0" 200 4919 "*Мой сайт*/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0"
    9. *Мой айпи* - - [07/Apr/2013:19:38:27 +0300] "GET /administrator/index.php?option=com_categories&section=com_content HTTP/1.0" 200 4947 "*Мой сайт*/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0"
    10. *Мой айпи* - - [07/Apr/2013:19:38:28 +0300] "GET /administrator/index.php HTTP/1.0" 200 4919 "*Мой сайт*/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0"
    11. *Мой айпи* - - [07/Apr/2013:19:38:30 +0300] "GET /administrator/index.php?option=com_categories&section=com_content HTTP/1.0" 200 4947 "*Мой сайт*/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0"


    Второй лог (Логи ошибок Apache):
    (при заходе в админку тут никаких ошибок не выдает)

    Код (CODE):
    1. [Sun Apr 07 19:28:15 2013][error][client *Мой айпи*] File does not exist: /home/*/domains/*Мой сайт*/public_html/404.shtml, referer: http://*Мой сайт*/templates/siteground-j15-24/css/template.css
    2. [Sun Apr 07 19:28:15 2013][error][client *Мой айпи*] File does not exist: /home/*/domains/*Мой сайт*/public_html/templates/siteground-j15-24/images/blue, referer: http://*Мой сайт*/templates/siteground-j15-24/css/template.css
    3. [Sun Apr 07 19:28:15 2013][error][client *Мой айпи*] File does not exist: /home/*/domains/*Мой сайт*/public_html/404.shtml, referer: http://*Мой сайт*/templates/siteground-j15-24/css/template.css
    4. [Sun Apr 07 19:28:16 2013][error][client *Мой айпи*] File does not exist: /home/*/domains/*Мой сайт*/public_html/templates/siteground-j15-24/images/.jpg, referer: http://*Мой сайт*/templates/siteground-j15-24/css/template.css
    5. [Sun Apr 07 19:28:16 2013][error][client *Мой айпи*] File does not exist: /home/*/domains/*Мой сайт*/public_html/404.shtml, referer: http://*Мой сайт*/templates/siteground-j15-24/css/template.css
    6. [Sun Apr 07 19:28:16 2013][error][client *Мой айпи*] File does not exist: /home/*/domains/*Мой сайт*/public_html/templates/siteground-j15-24/images/blue, referer: http://*Мой сайт*/templates/siteground-j15-24/css/template.css
    7. [Sun Apr 07 19:28:16 2013][error][client *Мой айпи*] File does not exist: /home/*/domains/*Мой сайт*/public_html/404.shtml, referer: http://*Мой сайт*/templates/siteground-j15-24/css/template.css
    8. [Sun Apr 07 19:28:16 2013][error][client *Мой айпи*] File does not exist: /home/*/domains/*Мой сайт*/public_html/templates/siteground-j15-24/images/.jpg, referer: http://*Мой сайт*/templates/siteground-j15-24/css/template.css
    9. [Sun Apr 07 19:28:16 2013][error][client *Мой айпи*] File does not exist: /home/*/domains/*Мой сайт*/public_html/404.shtml, referer: http://*Мой сайт*/templates/siteground-j15-24/css/template.css
    10. [Sun Apr 07 19:28:16 2013][error][client *Мой айпи*] File does not exist: /home/*/domains/*Мой сайт*/public_html/templates/siteground-j15-24/images/blue, referer: http://*Мой сайт*/templates/siteground-j15-24/css/template.css
    11. [Sun Apr 07 19:28:16 2013][error][client *Мой айпи*] File does not exist: /home/*/domains/*Мой сайт*/public_html/404.shtml, referer: http://*Мой сайт*/templates/siteground-j15-24/css/template.css


    Получается никаких ошибок нет ?
     
  10. draff
    Offline

    draff Russian Joomla! Team Команда форума

    Регистрация:
    17.01.2011
    Сообщения:
    6 041
    Симпатии:
    518
    Пол:
    Мужской
    А это что ?
    *Мой айпи* - - [07/Apr/2013:19:38:13 +0300] "GET /administrator/index.php?option=com_content HTTP/1.0" 500 290 "*Мой сайт*/administrator/index.php" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0"
     
  11. Offline

    KolllaK Недавно здесь

    Регистрация:
    12.08.2010
    Сообщения:
    14
    Симпатии:
    0
    Пол:
    Мужской
    Увидел, понял. Что с этим дальше делать ?
    Что-то колупать в сайте или к хостеру ?
     
  12. draff
    Offline

    draff Russian Joomla! Team Команда форума

    Регистрация:
    17.01.2011
    Сообщения:
    6 041
    Симпатии:
    518
    Пол:
    Мужской
  13. Offline

    KolllaK Недавно здесь

    Регистрация:
    12.08.2010
    Сообщения:
    14
    Симпатии:
    0
    Пол:
    Мужской
    Спасибо за шикарный совет!
    А можно более детально ?
    Или проще сделать\заказать новый сайт ?
    Знал бы я что где и как налаживать - не пришел бы на форум.
     
  14. draff
    Offline

    draff Russian Joomla! Team Команда форума

    Регистрация:
    17.01.2011
    Сообщения:
    6 041
    Симпатии:
    518
    Пол:
    Мужской
    Установи новую Joomla твоей версии в подпапку.Посмотри как работает.
    Перезалей файлы /com_conent и проверь таблицу __components and __content в старой J.
     
    KolllaK нравится это.
  15. Offline

    KolllaK Недавно здесь

    Регистрация:
    12.08.2010
    Сообщения:
    14
    Симпатии:
    0
    Пол:
    Мужской
    Спасибо. Полез колупаться.
     
  16. Offline

    KolllaK Недавно здесь

    Регистрация:
    12.08.2010
    Сообщения:
    14
    Симпатии:
    0
    Пол:
    Мужской
    draff, спасибо за попытку помочь, сайт банально был хакнут через template.
    Хороший друг, программист, помог восстановить сайт из древнего дампа.
    Все заработало. Проблема была не в БД и не в папке Администратор ( Но попытка не пытка )
     

Поделиться этой страницей

Загрузка...