Решено! Перестали грузиться текстовые константы из языковых пакетов

Тема в разделе "Кодировки, ошибки отображения (крякозябры)", создана пользователем Axl, 16.07.2013.

  1. Offline

    Axl Недавно здесь

    Регистрация:
    16.07.2013
    Сообщения:
    3
    Симпатии:
    0
    Пол:
    Мужской
    Возникла следующая проблема, смотрите скрин.

    Администраторов на сайте несколько, никто не сознается когда и что произошло. У хостера есть несколько резервных версий сайта, откат ни на одну не помог. Обновление с версии 2.5.6 до версии 2.5.11 тоже успеха не принесло.
    Сбился весь текст, как на главной, так и в админке. Из языковых пакетов ничего не подгружается (En, Ru). Пробовал искать решение этой проблемы в гугле, ничего не нашел, был схожий вариант, там помог откат на уровне хостера.
    может кто подскажет как быть.
    Заранее спасибо!
     

    Вложения:

    • screen.jpg
      screen.jpg
      Размер файла:
      75.5 КБ
      Просмотров:
      5
  2.  
  3. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Включить режим отладки языка и смотреть.
    Можно прямо в configuration.php выставить:
    Код (PHP):
    1. public $debug_lang = '1';
    2. public $error_reporting = 'maximum';
     
    Axl нравится это.
  4. Offline

    Axl Недавно здесь

    Регистрация:
    16.07.2013
    Сообщения:
    3
    Симпатии:
    0
    Пол:
    Мужской
    спасибо огромное, как оказалось у хостера заблокирована функция parse_ini_file(). Сейчас разбираюсь почему это произошло. Сайт работал больше года.
     
  5. Offline

    Axl Недавно здесь

    Регистрация:
    16.07.2013
    Сообщения:
    3
    Симпатии:
    0
    Пол:
    Мужской
    хостер включил функцию parse_ini_file(), все работает!
    Еще раз спасибо за совет включить дебаг и логи.

    Тему закрываю.
     

Поделиться этой страницей

Загрузка...