Проблема с удалением фото товара из папки additional через VM (фото ошибки прилагается)

Тема в разделе "VirtueMart", создана пользователем holovla, 31.07.2013.

  1. Offline

    holovla Пользователь

    Регистрация:
    25.07.2012
    Сообщения:
    58
    Симпатии:
    2
    Пол:
    Мужской
    Добрый день!

    Помогите, пожалуйста, разобраться со следующим моментом :
    J1,5 v1

    При попытке удалить товар, вм не удаляет изображение из папки additional (доступ 777)
    Выдает ошибку такую (см фото) и из за этого приходится лезть на сервер, удалять руками, что крайне неудобно в связи с большим массивом фото.

    Тоесть в итоге, товар сам удаляется, а вот фото - нет! ( Подскажите, пожалуйста, куда копать? или если кто сталкивался, то может есть решение? надоела ошибка дико

    Заранее примного благодарен за любую помощь и совет !
     

    Вложения:

  2.  
  3. Offline

    holovla Пользователь

    Регистрация:
    25.07.2012
    Сообщения:
    58
    Симпатии:
    2
    Пол:
    Мужской
    Никто не знает? :((
     
  4. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Последнее редактирование: 31.03.2014
  5. Offline

    holovla Пользователь

    Регистрация:
    25.07.2012
    Сообщения:
    58
    Симпатии:
    2
    Пол:
    Мужской
    Совсем не то что нужно ((
    Скажите пожалуйста, может ли эта ошибка быть связана с тем, что в ВМ неверно прописан путь к фото на сервере? Если да, то где это можно посмотреть?
    заранее спс
     
  6. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    А что нужно то? А если думаешь, что кто-то будет медитировать на эту древность... то желаю удачи. :)

    скрипт позволяет удалить весь мусор из папок.

    Может. Смотреть в базе либо в самом товаре перед удалением.
     
  7. Offline

    holovla Пользователь

    Регистрация:
    25.07.2012
    Сообщения:
    58
    Симпатии:
    2
    Пол:
    Мужской
    Нужно понять почему не удаляет все фото конкретного товара при удалении этого товара в вм (я фото привел в первом посте)

    А какая разница какая версия? Ну старая ну древняя , ну и что, за то должна быть изучена полностью.. не переделывать же все из за того что цифры 1,5 ..миграция слишком сложная в моем случае

    Так а мусора то нет..

    Ничего не понятно ,может ли быть неверно в каком то конфиге что то прописано? Где глянуть чтобы проверить это? Название файла/строчка или что нибудь..

    Четкая проблема - вм не удаляет фото товара , при удалении самого товара через интерфейс вм.. на фото все явно же видно
     
    Последнее редактирование: 07.08.2013
  8. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Разница в том, что даже не 1.1.9. А чем старее, тем больше глюков. Поэтому я обычно сначала обновляю до последних версий, а уж затем ошибки исправляю, если остались. По-моему так правильнее.

    И для меня мусор - неудаленные фото.

    Вряд ли, тогда фото вообще не показывались бы. Они были видны до удаления товара?
     
  9. Offline

    holovla Пользователь

    Регистрация:
    25.07.2012
    Сообщения:
    58
    Симпатии:
    2
    Пол:
    Мужской
    спасибо за ответ, да они все видно и все прекрасно работает, но если хочешь удалить товар, заходишь в вм, ищешь его по артикулу , нажимаешь удалить и сам товар удаляется, а вот фото не, пишет что невозможно удалить ((((
     

Поделиться этой страницей

Загрузка...