Joomla 3.0 Проблема обновления

Тема в разделе "Установка и обновление Joomla!", создана пользователем Velascues, 07.03.2014.

  1. Velascues
    Offline

    Velascues Недавно здесь

    Регистрация:
    11.01.2007
    Сообщения:
    31
    Симпатии:
    2
    Пол:
    Мужской
    Не могу обновить
    Установленная версия Joomla! 3.0.3
    Последняя версия Joomla! 3.2.2
    При попытки обновления вылезает окно: см.скриин. И после этого обновление зависает.
     

    Вложения:

    - Art - нравится это.
  2.  
  3. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Уже 3.2.3.

    Чтобы не было ошибки, возможно надо отключить левые плагины.
    Можно скачать пакет обновления http://joomlacode.org/gf/project/joomla/frs/?action=FrsReleaseBrowse&frs_package_id=6856 и установить пакет вручную - http://docs.joomla.org/J3.2:Upgrading_from_an_existing_version#Method_B_-_Install_Method
     
  4. Offline

    dominator Недавно здесь

    Регистрация:
    23.05.2014
    Сообщения:
    5
    Симпатии:
    0
    Пол:
    Мужской
    Отчего при обновлении с Joomla 3.0 на 3.2 возникает такая ошибка? Fatal error: Call to a member function isAdmin() on a non-object in home\localhost\www\backup\plugins\system\remember\remember.php on line 42. Везде пишут, что проблема решается так: переименовать remember.php, пофиксить базу, потом переименовать обратно и все заработает. Пробовал, но выдает уже другую ошибку: Fatal error: Call to a member function getInt() on a non-object in home\localhost\www\test\administrator\components\com_postinstall\models\messages.php on line 37. Как это можно полечить?
     
    Последнее редактирование: 23.05.2014
  5. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Где возникают ошибки?

    Перезалить вручную ВСЕ файлы Joomla. Как минимум можно так же переименовать этот файл.
     
  6. Offline

    dominator Недавно здесь

    Регистрация:
    23.05.2014
    Сообщения:
    5
    Симпатии:
    0
    Пол:
    Мужской
    Ошибка выползает сразу после обновления вместо сайта.
    Переименование дает только вход в админку, фикс базы ничего не дает. "Схема базы данных (3.2.3-2014-02-20) не соответствует версии CMS (3.2.3)."
    Перезалить - это накатить сверху всю джумлу? Или файлы из update, которыми обновлялся?
     
  7. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Можно всю без папки installation, можно из update.

    Это старая известная "проблема" - http://docs.joomla.org/J3.x:Databas...014-02-20)_does_not_match_CMS_version_(3.2.3)
    Но ведь уже есть Joomla 3.2.4.
     
  8. Offline

    dominator Недавно здесь

    Регистрация:
    23.05.2014
    Сообщения:
    5
    Симпатии:
    0
    Пол:
    Мужской
    В общем, понятно, что ни черта непонятно. С 3.2.4 все то же самое. А по старой известной проблеме уповод сидел, переводил это переливание из пустого в порожнее. Ссылки тамошние на какой-то патч никуда не ведут.
     
  9. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Что именно?

    которая вовсе и не проблема, просто надпись выводится
     
  10. Offline

    dominator Недавно здесь

    Регистрация:
    23.05.2014
    Сообщения:
    5
    Симпатии:
    0
    Пол:
    Мужской
    Я спрашивал - можно ли без вышеуказанных эрроров обновить Джумлу с сайтом с 3.0.х до 3.2.х. Ответа нигде пока не нашел. Все пускаются в пространные объяснения, прямого касательства к моей проблеме не имеющие.
     
  11. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Без понятия. Достаточно пространно? С такими вопросами и будут пространные ответы.

    Перезаливка файлов что-нибудь дала?
     
  12. Offline

    dominator Недавно здесь

    Регистрация:
    23.05.2014
    Сообщения:
    5
    Симпатии:
    0
    Пол:
    Мужской
    Не-а. Та же шняга. Да я уже сделал все путем геморроя. Развернул бэкап на локалке, из БД сделал экспорт нужных данных, залил лаунчер с нужным шаблоном, уже его обновил до 3.2.4. Потом импортировал сохраненные данные в новую БД
     
  13. alixsjr
    Offline

    alixsjr Недавно здесь

    Регистрация:
    16.04.2013
    Сообщения:
    17
    Симпатии:
    0
    Пол:
    Мужской
    Спустя пару лет проблема так и не решилось что ли? С 3.1 обновится не могу :
    Fatal error: Call to a member function isAdmin() on a non-object in /var/www/user/data/www/sayt.ru/plugins/system/remember/remember.php on line 42
     
  14. Asylum
    Offline

    Asylum специалист

    Регистрация:
    09.02.2007
    Сообщения:
    2 571
    Симпатии:
    152
    Пол:
    Мужской
    Отключите на время обновления плагин "запомнить меня" или как то так (remember)
     
    Последнее редактирование: 25.11.2016
  15. alixsjr
    Offline

    alixsjr Недавно здесь

    Регистрация:
    16.04.2013
    Сообщения:
    17
    Симпатии:
    0
    Пол:
    Мужской
    Ага уже сделал теперь в поисках решения новой проблемы)
    При добавлении материала ошибка: Fatal error: Class 'Joomla\String\StringHelper' not found in .../language/ru-RU/ru-RU.localise.php on line 565

    Менеджер расширений - База данных
    Версия обновления (из #__extensions): 3.2.7.

    А язык русский для версии 3.6.2.2 английский для 3.2.3
    Теперь не могу понять как это изменить!
    Не подскажите?
     
  16. draff
    Offline

    draff Russian Joomla! Team Команда форума

    Регистрация:
    17.01.2011
    Сообщения:
    6 044
    Симпатии:
    519
    Пол:
    Мужской
    Ну и обновляйся дальше к новым версиям,в которых пофиксили ошибки .
    А эта ошибка связана с namespase
    Код (PHP):
    1. use \Joomla\String\StringHelper;
     
  17. alixsjr
    Offline

    alixsjr Недавно здесь

    Регистрация:
    16.04.2013
    Сообщения:
    17
    Симпатии:
    0
    Пол:
    Мужской
    А дальше некуда дело в том что я обновился уже 25-26 ноября отключив remember
    Менеджер расширений - База данных, исправил бд.
    И получается теперь что joomla 3.6.2 по факту (не помню точно до какой обновил), в БД 3.2.7, а языковой файл не соответствует версии вот и ошибка насколько я понял из сообщений на форумах.
     
  18. draff
    Offline

    draff Russian Joomla! Team Команда форума

    Регистрация:
    17.01.2011
    Сообщения:
    6 044
    Симпатии:
    519
    Пол:
    Мужской
    А базу пофиксить в менеджере расширений пробовал ? И Джумла 3.6.4 актуальная версия
     
  19. Asylum
    Offline

    Asylum специалист

    Регистрация:
    09.02.2007
    Сообщения:
    2 571
    Симпатии:
    152
    Пол:
    Мужской
    Самый простой вариант, берете свежий дистрибутив Джумлы, заливаете поверху с заменой файлов, удаляете папку инсталл, потом смотрите в админ панели базу на ошибки и если нужно жмете кнопку "исправить"

    И конечно этот метод применим только при обновлении одной ветки
     
  20. alixsjr
    Offline

    alixsjr Недавно здесь

    Регистрация:
    16.04.2013
    Сообщения:
    17
    Симпатии:
    0
    Пол:
    Мужской
    "Ветка" - это папка или...?
    --- добавлено: 04.12.2016 в 15:04, первое сообщение размещено: 04.12.2016 в 11:01 ---
    Намутил тут воду действительно обновился с 3.1 до 3.2.7, а как дальше обновится в панели написано: You already have the latest Joomla! version, 3.2.7. А Последняя актуальная 3.6* Как далее? Только поверх?
     

Поделиться этой страницей

Загрузка...