Проблема Ошибки при установке Joomshoping

Тема в разделе "JoomShopping", создана пользователем tiptopvkr, 25.12.2014.

  1. tiptopvkr
    Offline

    tiptopvkr Пользователь

    Регистрация:
    22.07.2011
    Сообщения:
    157
    Симпатии:
    1
    Пол:
    Мужской
    Уважаемые знатоки Joomla - помогите пожалуйста. Пытаюсь поставить Joomshoping на Joomla 1.5. Испробовал несколько версий уже но все равно появляются такие сообщения:
    Strict Standards: Non-static method JLoader::import() should not be called statically in /libraries/loader.php on line 186
    Strict Standards
    : Non-static method JApplicationHelper::getPath() should not be called statically, assuming $this from incompatible context in /libraries/joomla/application/component/helper.php on line 168

    И многие другие. Подскажите пожалуйста как это исправить и в чем может быть проблема.
     
  2.  
  3. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Зачем????? ...на такую древность ставить..

    Думаю нужна версия 2.х или ниже.
    А сообщения отключаются в настройках сайта (хостинга).
     
  4. tiptopvkr
    Offline

    tiptopvkr Пользователь

    Регистрация:
    22.07.2011
    Сообщения:
    157
    Симпатии:
    1
    Пол:
    Мужской
    У меня просто другого выхода нет. Магазин сделанный и наполненный контентом. Заказчик потребовал организации вывода списка подтоваров в некоторых категориях. Я не умею это реализовать на virtuemart на котором сделан магаз. но нашел что это можно сделать на Joomshopping Потому вот такая сиуация. С нуля я бы делал на 2.5 не иначе.

    Кстати проблема решилась. Оказывается это из-за версии рнр. На сервере стояло 5.4 для сайта. сменил на 5.2 и все заработало. забыл что 1.5 не любит версии выше 5.2
     
  5. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Дело не в Joomla и не в Joomshopping, а в версии PHP (подразумеваю PHP 5.3+), которая вываливает в "ошибки" всё, что угодно.
    --- добавлено: 25.12.2014, первое сообщение размещено: 25.12.2014 ---
    На сегодня я бы делал на J3.3+

    Это не 1.5 не любит, а PHP не любит, чтобы скрипты запускали устаревшими способами. :)
     
  6. tiptopvkr
    Offline

    tiptopvkr Пользователь

    Регистрация:
    22.07.2011
    Сообщения:
    157
    Симпатии:
    1
    Пол:
    Мужской
    В любом случае они друг друга недолюбливают) А относительно 3.3 я как то консервативно отношусь... 2.5 уже проверил и защитить могу а 3.3 еще совсем не знаю и не практиковал. Стремно как то...
     
  7. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Кому как.... и с какой стороны посмотреть.. )

    Стремно не стремно, а жизнь J2.5 подходит к концу... И мне непонятно, чем отличается защита 2.5 от 3.3.
     
  8. tiptopvkr
    Offline

    tiptopvkr Пользователь

    Регистрация:
    22.07.2011
    Сообщения:
    157
    Симпатии:
    1
    Пол:
    Мужской
    Сегласен. Я несколько лет назад так же смотрел на 2.5)) Придется осваивать 3-ку. Думаю будет интересно)
     
  9. Asylum
    Offline

    Asylum специалист

    Регистрация:
    09.02.2007
    Сообщения:
    2 568
    Симпатии:
    152
    Пол:
    Мужской
    Поддержка 2.5 закончилась, как Вы будете ее защищать когда в ней найдут дыру? Раньше ее можно было просто обновить
     

Поделиться этой страницей

Загрузка...