Joomla 3.x При подключении плеера, выходит ошибка

Тема в разделе "Установка и обновление расширений Joomla", создана пользователем tmpnikl, 27.08.2015.

  1. Offline

    tmpnikl Пользователь

    Регистрация:
    08.05.2015
    Сообщения:
    74
    Симпатии:
    0
    Пол:
    Мужской
    перешёл с дж.2 на дж. 3, теперь потихоньку включаю расширения, но почему то при включении расширения HD Webplayer, возникает ошибка Fatal error: Class WebplayerModelHtml5 cannot extend from interface JModel, как можно её исправить?
     
  2.  
  3. woojin
    Offline

    woojin Местный Команда форума

    Регистрация:
    31.05.2009
    Сообщения:
    3 209
    Симпатии:
    335
    Пол:
    Мужской
    или переписать самому ручками или скачать/купить версию данного плейера под J3.x
     
    tmpnikl нравится это.
  4. Offline

    tmpnikl Пользователь

    Регистрация:
    08.05.2015
    Сообщения:
    74
    Симпатии:
    0
    Пол:
    Мужской
    А не подскажите какой можно использовать видеоплеер для джумлы 3..., а то я уже устал устанавливать их и сносить, мне надо, чтоб было как в предыдущем плеере можно было в материале написать примерно {webplayer width=550 height=450 category=,cinema}
     
  5. woojin
    Offline

    woojin Местный Команда форума

    Регистрация:
    31.05.2009
    Сообщения:
    3 209
    Симпатии:
    335
    Пол:
    Мужской
    tmpnikl нравится это.
  6. lev
    Offline

    lev специалист

    Регистрация:
    21.12.2007
    Сообщения:
    676
    Симпатии:
    40
    Пол:
    Мужской
  7. draff
    Offline

    draff Russian Joomla! Team Команда форума

    Регистрация:
    17.01.2011
    Сообщения:
    6 054
    Симпатии:
    520
    Пол:
    Мужской
    tmpnikl нравится это.
  8. Offline

    tmpnikl Пользователь

    Регистрация:
    08.05.2015
    Сообщения:
    74
    Симпатии:
    0
    Пол:
    Мужской
    Спасибо за ответы...не для дискуссии, а так просто размышления, уже который раз сталкиваюсь с отсутствием поддержки функций более ранних версий(которые надо заменять на другие), наверное как следствие некоммерческого подхода...:-(, в коммерческих продуктах совместимость функций аж с 90-ых годов..
     
  9. lev
    Offline

    lev специалист

    Регистрация:
    21.12.2007
    Сообщения:
    676
    Симпатии:
    40
    Пол:
    Мужской
    На все есть график поддержки, даже на софт, хочется вам это или нет, но эти изменения необходимы для разработчиков.
    http://www.joomla.org/3/ru/
    df1458c974ac.jpg
     
    tmpnikl нравится это.
  10. draff
    Offline

    draff Russian Joomla! Team Команда форума

    Регистрация:
    17.01.2011
    Сообщения:
    6 054
    Симпатии:
    520
    Пол:
    Мужской
    Наверно потому что обновление Джумла и установленных сторонних расширений предназначено для разработчиков, а не домохозяек.
    В FAQ обновления Джумла с 2.5 до 3.4 рекомендуют, перед обновлением проверить, что установленные сторонние расширения поддерживаются Джумла 3.
     

Поделиться этой страницей

Загрузка...