Проблема Ошибка: Class 'JArchive' not found

Тема в разделе "Ошибки при работе с Joomla", создана пользователем Aleksandr_, 25.01.2016.

  1. Offline

    Aleksandr_ Недавно здесь

    Регистрация:
    29.08.2013
    Сообщения:
    2
    Симпатии:
    0
    Пол:
    Мужской
    Здравствуйте возможно кто либо может подсказать или помочь.
    Стоит Джумла 3.4.8, обновил до этой версии 24.12.16
    До обновления при попытке установить модуль или плагин материлось следующим образом
    Fatal error: Class 'JArchive' not found in /home/a/artdeluxe/artdeluxe46.ru/public_html/libraries/cms/installer/helper.php on line 131
    И соответственно ничего ставить не хотела.
    Я ее обманывал, скидывал в темп распакованную папку и устанавливал из каталога.
    После обновления поумнела видимо и так ее уже не обманешь, вообще никак не ставить ошибку дает ту же самую.
    131 строчка в helper.php это:
    $extract = JArchive::extract($archivename, $extractdir);
     
  2.  
  3. woojin
    Offline

    woojin Местный Команда форума

    Регистрация:
    31.05.2009
    Сообщения:
    3 209
    Симпатии:
    335
    Пол:
    Мужской
    попробуй в tmp создать новый каталог и скинь в него распакованный архив, возможно прокатит!
    неполучится, качай полную версию 3.4.8 и просто заливай поверх тех файлов которые есть, но без каталога install
     
  4. Offline

    Aleksandr_ Недавно здесь

    Регистрация:
    29.08.2013
    Сообщения:
    2
    Симпатии:
    0
    Пол:
    Мужской
    Благодарствую за ответ
    то что в tmp каталог это да, я ж говорил ее дурил таким образом, но не всегда прокатывает что крайне неудобно
    Полную версию я могу без последствий залить? У меня там Nano 3 стоит в шаблонах настроенный и сайт живой работающий
    А то что он ругается на класс JAarchive? Нельзя это как нить волшебный образом посредством бубна и "еб ее джумлу мат"ь починить?
    --- добавлено: 26.01.2016, первое сообщение размещено: 26.01.2016 ---
    Решил. Не сам, посоветовали, было выключено кэширование
     
  5. woojin
    Offline

    woojin Местный Команда форума

    Регистрация:
    31.05.2009
    Сообщения:
    3 209
    Симпатии:
    335
    Пол:
    Мужской
    вообще его ни когда не включаю и всё работает на УРА!
     

Поделиться этой страницей

Загрузка...