Проблема Joomla выдает 404 ошибку если Title страницы отличается от Алиаса (url страницы)

Тема в разделе "Joomla и SEF (ЧПУ)", создана пользователем Boarworm, 11.11.2016.

  1. Offline

    Boarworm Недавно здесь

    Регистрация:
    10.02.2012
    Сообщения:
    7
    Симпатии:
    0
    Пол:
    Мужской
    У кого-то было такое? Модули все отключал, не помогло.
    Если алиас создается автоматически, то статья открывается нормально, а если самому прописать алиас, то выдается 404 ошибка
     
  2.  
  3. OlegK
    Offline

    OlegK Russian Joomla! Team Команда форума ⇒ Профи ⇐

    Регистрация:
    17.01.2011
    Сообщения:
    7 795
    Симпатии:
    763
    Пол:
    Мужской
    А если отключить автоматическое создание алиаса?
     
  4. Offline

    Boarworm Недавно здесь

    Регистрация:
    10.02.2012
    Сообщения:
    7
    Симпатии:
    0
    Пол:
    Мужской
    upload_2016-11-11_16-54-0.png

    Сейчас так. Или вы не об этом?
    Пробовал отключить ЧПУ, тогда вообще любая ссылка ведет на главную.
     
  5. OlegK
    Offline

    OlegK Russian Joomla! Team Команда форума ⇒ Профи ⇐

    Регистрация:
    17.01.2011
    Сообщения:
    7 795
    Симпатии:
    763
    Пол:
    Мужской
    При создании материала в поле алиас прописал свой алиас, отличный от title - в блог категории материал вывелся и я нормально перешел по ссылке.
    Кнопки отключения нет. Только при создании материала сам создаешь алиас или Джумла автоматом.
     
  6. Offline

    Boarworm Недавно здесь

    Регистрация:
    10.02.2012
    Сообщения:
    7
    Симпатии:
    0
    Пол:
    Мужской
    Если джумла создает автоматом (алиас = тайтл) тогда работает, а если самому что-то прописать в алиас, то выдает 404 ошибку.
     
  7. Asylum
    Offline

    Asylum Местный => Cпециалист <=

    Регистрация:
    09.02.2007
    Сообщения:
    2 746
    Симпатии:
    160
    Пол:
    Мужской
    Напишите пример неработающего алиаса
     

Поделиться этой страницей

Загрузка...