Проблема Добавление картинок

Тема в разделе "Ошибки при работе с Joomla", создана пользователем svich123, 20.02.2019.

  1. Offline

    svich123 Недавно здесь

    Регистрация:
    20.02.2019
    Сообщения:
    6
    Симпатии:
    0
    Joomla 3.9.3 создаю материал. В него добавляю картинки. При добавлении примерно половины картинок наблюдаю такую проблему:
    картинку добавил - сохранил - на сайте открывается пустая страница (отображается только заголовок материала)
    картинку удалил - сохранил - на сайте открывается всё содержимое

    то есть часть картинок отображается нормально, а часть нет.
    Куда копать? Какие данные еще предоставить?
     
  2.  
  3. OlegK
    Offline

    OlegK Russian Joomla! Team Команда форума ⇒ Профи ⇐

    Регистрация:
    17.01.2011
    Сообщения:
    7 192
    Симпатии:
    655
    Пол:
    Мужской
    Формат картинки в нижнем регистре ? Например не .PNG ?
    Может в картинке вирус прописан в формате пхп кода.
     
  4. Offline

    svich123 Недавно здесь

    Регистрация:
    20.02.2019
    Сообщения:
    6
    Симпатии:
    0
    в настройках форматы добавлены в обоих режимах. картинка - фото с телефона. сомневаюсь что там вирус.
     
  5. OlegK
    Offline

    OlegK Russian Joomla! Team Команда форума ⇒ Профи ⇐

    Регистрация:
    17.01.2011
    Сообщения:
    7 192
    Симпатии:
    655
    Пол:
    Мужской
    Проверь ошибки в консоли браузера и ссылки на картинки что отдают 200 или 404 .
     
  6. Offline

    svich123 Недавно здесь

    Регистрация:
    20.02.2019
    Сообщения:
    6
    Симпатии:
    0
    когда в материале нет проблемных картинок - всё отображается на сайте. у изображений код 200
    когда в материале присутствуют эти проблемные картинки то отображается только заголовок материала. не прогружаются ни одни картинки. код отсутствует соответственно. и в консоли и в логах
     
  7. OlegK
    Offline

    OlegK Russian Joomla! Team Команда форума ⇒ Профи ⇐

    Регистрация:
    17.01.2011
    Сообщения:
    7 192
    Симпатии:
    655
    Пол:
    Мужской
    Переключи на стандартный шаблон,отключи сторонние плагины и пробуй .
     
  8. Offline

    svich123 Недавно здесь

    Регистрация:
    20.02.2019
    Сообщения:
    6
    Симпатии:
    0
    protostar пробовал. насчет сторонних плагинов - их нет. есть mavik Thumbnails его убрать не могу - он нужен. с другими картинками он нормально работает. вряд ли дело в нём
     
  9. OlegK
    Offline

    OlegK Russian Joomla! Team Команда форума ⇒ Профи ⇐

    Регистрация:
    17.01.2011
    Сообщения:
    7 192
    Симпатии:
    655
    Пол:
    Мужской
    Временно отключить для тестирования можно и отключить. А показ ошибок пхп на максимум пробовал установить ?
    Помнится что именно плагин мавика генерировал ошибки на новых версиях ДЖумла .
     
    svich123 нравится это.
  10. Offline

    svich123 Недавно здесь

    Регистрация:
    20.02.2019
    Сообщения:
    6
    Симпатии:
    0
    с отключенным мавиком всё отображается.
    посоветуйте замену мавику
    или лучше способ лечения мавика
     
  11. OlegK
    Offline

    OlegK Russian Joomla! Team Команда форума ⇒ Профи ⇐

    Регистрация:
    17.01.2011
    Сообщения:
    7 192
    Симпатии:
    655
    Пол:
    Мужской
    плагин SP Thumbnail.
     
  12. Offline

    svich123 Недавно здесь

    Регистрация:
    20.02.2019
    Сообщения:
    6
    Симпатии:
    0
    подведу итог
    SP Thumbnail не нашел в JED (из других мест ставить как то боязно)
    как то победился мавик.
    удалил его с сайта,
    поставил из JED - не заработало - удалил
    поставил из файла (по ссылке из JED) - не заработало - удалил
    поставил опять из JED - он заработал. добавил все проблемные картинки - они отлично отображаются и увеличиваются
     

Поделиться этой страницей

Загрузка...