Проблема с кодировкой после инсталляции на локальном сервере

Тема в разделе "Кодировки, ошибки отображения (крякозябры)", создана пользователем Daglus, 22.08.2007.

  1. Daglus
    Offline

    Daglus Недавно здесь

    Регистрация:
    08.03.2007
    Сообщения:
    62
    Симпатии:
    0
    После установки на локальном сервере ( процесс установки прошел нормально без ошибок), при загрузки сайта у меня не отображается русский язык, в админ-панели 90% символов также показывается как знаки вопроса...
    Кодировка базы cp_1251_general_ci таблицы также создались в етой кодировке,добавил строку в шаблон указывающую нужную кодировку, добавил в .htaccess adddefaultcharset win1251
    Ничего не помогло..


    Использовал:
    Joomla! RE 1.0.13 и Joomla! RE 1.0.12

    appserv-win32-2.5.8 в его составе:
    Apache Web Server Version 2.0.55
    PHP Script Language Version 5.1.1
    MySQL Database Version 5.0.16
    phpMyAdmin Database Manager Version 2.6.4-pl4


    Что еще можно предпринять? Заранее благодарен.
     
  2.  
  3. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Ответ: Проблема с кодировкой после инсталляции на локальном сервере

    Попробуй прочитать FAQ по Joomla
     
  4. Offline

    Stealth Недавно здесь

    Регистрация:
    12.10.2005
    Сообщения:
    3
    Симпатии:
    0
    Пол:
    Мужской
    Ответ: Проблема с кодировкой после инсталляции на локальном сервере

    Обычно в таких случаях помогает следующая строчка в /etc/my.cnf
    init-connect = set names cp1251

    А еще можно вот сюда вставить в /etc/my.cnf:

    # The following options will be passed to all MySQL clients
    [client]
    #password = your_password
    port = 3306
    socket = /tmp/mysql.sock
    default-character-set = cp1251
    -------------------------------
    #skip-networking
    server-id = 1
    default-character-set = cp1251
    ------------------------------
    [mysql]
    no-auto-rehash
    # Remove the next comment character if you are not familiar with SQL
    #safe-updates

    default-character-set = cp1251


    Мне помогло ;)
     

Поделиться этой страницей

Загрузка...