проблема с com_banners и com_artbannersplus

Тема в разделе "Сообщения об ошибках", создана пользователем agruts, 03.07.2008.

  1. agruts
    Offline

    agruts Russian Joomla! Team

    Регистрация:
    01.03.2006
    Сообщения:
    612
    Симпатии:
    21
    Пол:
    Мужской
    После установки обнаружил, что не отображаются баннеры.
    Клиенты, категории и баннеры все присутствуют.
    Оказывается, ругается вот на что:
    (artbannersplus)
    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /administrator/components/com_artbannersplus/admin.artbannersplus.php on line 790

    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /administrator/components/com_artbannersplus/admin.artbannersplus.php on line 803.

    дефолтный com_banners:
    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /administrator/components/com_banners/admin.banners.php on line 144

    Кто-то сталкивался уже?
     
  2.  
  3. sectus
    Offline

    sectus специалист

    Регистрация:
    19.04.2006
    Сообщения:
    1 210
    Симпатии:
    46
    Пол:
    Мужской
    Ответ: проблема с com_banners и com_artbannersplus

    Что-то с таблицами или запросами...
    SELECT cid, name FROM #__bannerclient - вот этот запрос видимо не работает.
     
  4. agruts
    Offline

    agruts Russian Joomla! Team

    Регистрация:
    01.03.2006
    Сообщения:
    612
    Симпатии:
    21
    Пол:
    Мужской
    Ответ: проблема с com_banners и com_artbannersplus

    странно, почему арбаннерс обращается в таблицу дефолтного компонента, если у него есть своя таблица #__artbannersplus_clients, в которой и хранятся данные о клиентах...
    в админке, при редактировании баннера список клиентов пустой.
    При этом клиенты и категории добаляются без проблем. Баннер добавить не получается, т.к. невозможно указать клиента и категорию.
    Я перенес в дустину базу компонента уже с данными, но новые добавить никак. Да и старые не показываются.
     
  5. sectus
    Offline

    sectus специалист

    Регистрация:
    19.04.2006
    Сообщения:
    1 210
    Симпатии:
    46
    Пол:
    Мужской
    Ответ: проблема с com_banners и com_artbannersplus

    я про дефолтный и говорил, у меня нет артбаннерс, а таблицы то целы?
     
  6. agruts
    Offline

    agruts Russian Joomla! Team

    Регистрация:
    01.03.2006
    Сообщения:
    612
    Симпатии:
    21
    Пол:
    Мужской
    Ответ: проблема с com_banners и com_artbannersplus

    таблицы целые, и данные все есть

    нашел где грабли :)
    /includes/database.php 300 строка

    Код (CODE):
    1. // для оптимизации расхода памяти можно раскомментировать
    2. следующие строки, но некоторые особенно кривые расширения сразу же отвалятся
    3.     //unset($this->_sql);
    4.    //return $this->_cursor;


    просто я после установки раскомментил эти строки и забыл про них, пока не врубил error_reporting(E_ALL)
    иногда полезно почитать нотисы :)))))
     
    Последнее редактирование: 04.07.2008
  7. Fanamura
    Offline

    Fanamura Доброта

    Регистрация:
    12.03.2007
    Сообщения:
    5 108
    Симпатии:
    159
    Пол:
    Мужской
    Ответ: проблема с com_banners и com_artbannersplus

    agruts, получается артбаннерс очень кривой :(
     
  8. agruts
    Offline

    agruts Russian Joomla! Team

    Регистрация:
    01.03.2006
    Сообщения:
    612
    Симпатии:
    21
    Пол:
    Мужской
    Ответ: проблема с com_banners и com_artbannersplus

    и com_banners тоже :)))
    хотя все остальные модули работали нормально, несмотря на то, что очевидно они более кривые, чем родной ком_баннерс....
     
  9. doctorgrif
    Offline

    doctorgrif специалист

    Регистрация:
    14.01.2008
    Сообщения:
    1 284
    Симпатии:
    66
    Пол:
    Мужской
    Ответ: проблема с com_banners и com_artbannersplus

    может поможет:
    удалил ком-банерс+зачистил БД от его таблиц (с предварительным дампом)
    установил артбаннерс - настроил клиентов, банеры
    потом заново поставил комбанерс - заработало:)
    но это на локалхосте под денвером, на хосте глумиться не решился
     
  10. agruts
    Offline

    agruts Russian Joomla! Team

    Регистрация:
    01.03.2006
    Сообщения:
    612
    Симпатии:
    21
    Пол:
    Мужской
    Ответ: проблема с com_banners и com_artbannersplus

    doctorgrif, на досуге поэкспериментирую :)
     
  11. Offline

    adamovrd Недавно здесь

    Регистрация:
    10.05.2011
    Сообщения:
    3
    Симпатии:
    0
    Пол:
    Мужской
    Re: Ответ: проблема с com_banners и com_artbannersplus

    поделитесь пожалуйста, как Вы заново его установили?
     

Поделиться этой страницей

Загрузка...