Joomla 1.0 На компах в США с нелокализованной XP кракозябры

Тема в разделе "Кодировки, ошибки отображения (крякозябры)", создана пользователем matalata, 09.08.2008.

  1. Offline

    matalata Недавно здесь

    Регистрация:
    10.10.2007
    Сообщения:
    2
    Симпатии:
    0
    Здравствуйте.
    Такая проблема:
    Joomla! 1.0.13 Stable [ Sunglow ] 21 July 2007 16:00 UTC + JoomlaFish
    на компах с русской версией XP (или с MRU) всё нормально на IE,
    а при просмотре русской страницы на оригиальной XP почему-то выбирается не та кодировка,
    хотя, если из браузера смотреть исходный текст, то там явно указана кодировка 1251.
    База тоже в кодировке 1251.

    Сайт www.language-bridge.com

    Где копаться?
     
  2.  
  3. Fanamura
    Offline

    Fanamura Доброта

    Регистрация:
    12.03.2007
    Сообщения:
    5 108
    Симпатии:
    159
    Пол:
    Мужской
    matalata, переименуйте htaccess.txt в .htaccess
    Там должно быть:
    AddDefaultCharset WINDOWS-1251
    CharsetSourceEnc windows-1251
    CharsetDisable On
     
  4. Offline

    matalata Недавно здесь

    Регистрация:
    10.10.2007
    Сообщения:
    2
    Симпатии:
    0
    Спасибо, Fanamura.
    Пока помогло не до конца.
    В Internet Explorer 7 автоматом выбирается почему-то KOI-8,
    в Mozilla Firefox всё работает.

    Пока грешу на то, что записал файл .htaccess не так (не убрал CR).
    И почему-то .htaccess не виден по ftp из total comander. Так и должно быть на unix-сервере?
     
  5. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Потому что он скрыт, что очень часто бывает. В ТС в меню FTP надо выбрать "Показывать скрытые файлы"

    И смотри FAQ на Joomla-Docs.ru - Сайт выводится в неверной кодировке. Если выставляю в браузере кодировку вручную, то всё OK.
     

Поделиться этой страницей

Загрузка...