Ограничение 10мб.

Тема в разделе "DOCMan", создана пользователем nuki, 12.10.2008.

  1. Offline

    nuki Недавно здесь

    Регистрация:
    12.07.2008
    Сообщения:
    11
    Симпатии:
    0
    Пол:
    Женский
    Сейчас стоит по дефолту ограничение в 10М, а нужно, чтобы можно было заливать файлы большим размером.
    Изменили php.ini
    upload_max_filesize= 100M
    post_max_size= 1000M
    В настройках Докмана 10М на 100М.
    Все равно не дает закачивать файлы более 10 мегов.

    Где-то ещё что-то надо изменить?
     
  2.  
  3. Dead Krolik
    Offline

    Dead Krolik специалист

    Регистрация:
    13.04.2007
    Сообщения:
    3 688
    Симпатии:
    101
    Пол:
    Мужской
  4. Offline

    quake3arena Недавно здесь

    Регистрация:
    03.12.2008
    Сообщения:
    107
    Симпатии:
    0
    Пол:
    Мужской
    ПХПинфо поправил, в настройках Докмана поправил.. локалхост ребутнул...Зашел под юзером с правами закачки....пытаюсь закачать файл выдает ---> Error uploading - Превышен максимально допустимый размер файла. ?? =O
     
  5. Offline

    quake3arena Недавно здесь

    Регистрация:
    03.12.2008
    Сообщения:
    107
    Симпатии:
    0
    Пол:
    Мужской
    вопрос снят... проблему решил с помощью пользователя rosalin (тема - http://joomla-support.ru/thread/2900/), хотя ошибки появлялись разные, а метод решения подошел одинаковый..
     
    Последнее редактирование модератором: 31.03.2014
  6. liga
    Offline

    liga Пользователь

    Регистрация:
    21.10.2008
    Сообщения:
    495
    Симпатии:
    18
    Пол:
    Мужской
    Ограничения это все ерунда. Если человек является единственным администратором сайта и у него есть FTP-доступ, то он через фтп-клиент может сам заливать доки любых размеров. Компонент DocMan, при установке, создает папку в корневом каталоге сайта "dmdocuments". В этой папке и хранятся все файлы. Можно просто перекинуть в эту папку любой файл, размером больше чем 20 мб (ибо это максимально допустимый объем закачиваемогоф файла). Зайти в админке в докмужика, создать новый документ и в разделе "файл", выбрать залитый файл. Только вот в названии файла желательно не использовать русские буквы.

    Вот реализация этой задумки http://gimnaziya-2.ru/index.php?option=com_docman&task=doc_details&gid=34&Itemid=86
     
    Последнее редактирование: 20.12.2008
  7. Offline

    Яуген Недавно здесь

    Регистрация:
    20.12.2008
    Сообщения:
    29
    Симпатии:
    1
    если хостер делает ограничение, то обойти его можно только договариваясь с администрацией
     
  8. Offline

    butle Недавно здесь

    Регистрация:
    20.04.2009
    Сообщения:
    2
    Симпатии:
    0
    Пол:
    Мужской
    Warning: require_once(Z:/home/000.net/www) [function.require-once]: failed to open stream: Permission denied in Z:\home\000.net\www\components\com_docman\includes_frontend\upload.php on line 69

    Fatal error: require_once() [function.require]: Failed opening required 'Z:/home/000.net/www' (include_path='.;/usr/local/php5/PEAR') in Z:\home\000.net\www\components\com_docman\includes_frontend\upload.php on line 69
    при попытке закачать zip архив выдаёт вот это. Как с этим бороться?
     
  9. liga
    Offline

    liga Пользователь

    Регистрация:
    21.10.2008
    Сообщения:
    495
    Симпатии:
    18
    Пол:
    Мужской
    butle, возможно у тебя в настройках стоит запрет на зип файлы, покапайся в настройках. Но не факт)
     

Поделиться этой страницей

Загрузка...