Почему некоторые картинки шаблона не отображаются?

Тема в разделе "Внешний вид, шаблоны, графика", создана пользователем dar18, 31.10.2008.

  1. Offline

    dar18 Недавно здесь

    Регистрация:
    11.10.2008
    Сообщения:
    2
    Симпатии:
    0
    Пол:
    Мужской
    Добрый всем день!
    Я новичок, поэтому не ругайтесь если что не так .
    Разместил сайт на хостинге RuCentra.
    На locslhoste он работал и выглядел в Мозилле нормально, да и в IE тоже.
    Но после заливки на хостинг (кстати, благодарю за фак по перемещению сайта с локалхоста на
    хостинг в интернете, очень помогло) не отображались картинки шаблона. Ни одна не отображалась.
    Я это дело поправил, прочитав как нужно сделать с поправкой на мою ситуацию.
    Теперь вроде нормально, но две картинки из шаблона никак не хотят отображаться:((
    Очень это странно. Ведь другие картинки из той же папки отображаются нормально,
    а эти не хотят.
    Сам сайт: http://www.taiga.nichost.ru/
    Может подскажете в чем может быть проблема?
    Где, как говориться, копать ?
    Заранее благодарю за ответ,
    с уважением,
    dar18.
     
    Последнее редактирование: 31.10.2008
  2.  
  3. Dead Krolik
    Offline

    Dead Krolik специалист

    Регистрация:
    13.04.2007
    Сообщения:
    3 688
    Симпатии:
    101
    Пол:
    Мужской
    Открой в браузере http://taiga.nichost.ru//templates/GreenBiz/images/logo.gif и посмотри что говорит. А говорит 404, то есть ее просто нет. Не залилась. Ну и проблема с двумя слэшами.
     
  4. Offline

    dar18 Недавно здесь

    Регистрация:
    11.10.2008
    Сообщения:
    2
    Симпатии:
    0
    Пол:
    Мужской
    Спасибо!
    Сейчас попробую исправить.

    Добавлено через 27 минут
    Получилось!
    Убрал второй слеш.
    Перезалил картинки.
    Воспользовался рекомендациями Sunder ( http://forum.joom.ru/index.php?topic=6797.0 )
    В файле шаблона index.php указал абсолютные пути к какртинкам.
    Как пример, было так:
    <img src="<?php echo $mosConfig_live_site; ?>/templates/GreenBiz/images/logo.gif" alt="Company Home" title="Company Home" />
    Сделал так:
    <img src="<?php echo $mosConfig_live_site;?>/templates/<?php echo $cur_template; ?>/images/logo.gif"
    alt="www.taiga.su" title="www.taiga.su" />
     
    Последнее редактирование: 31.10.2008

Поделиться этой страницей

Загрузка...