Joomla 1.5 Как обновить Joomla с 1.5.5 до 1.5.8

Тема в разделе "Установка и обновление Joomla!", создана пользователем Larsen, 30.11.2008.

  1. Offline

    Larsen Недавно здесь

    Регистрация:
    20.11.2008
    Сообщения:
    29
    Симпатии:
    0
    Пол:
    Мужской
    Хочу обновить Joomla с 1.5.5. до 1.5.8. Напиши подробную инструкцию
     
  2.  
  3. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
  4. Offline

    brustal Недавно здесь

    Регистрация:
    25.05.2009
    Сообщения:
    3
    Симпатии:
    0
    Шаг 3: Обновите файлы

    * 2. Закачайте пакет обновления по FTP на хостинг и распакуйте их там, использую менеджер файлов панели управления хостингом или с помощью терминала (SSH). Затем замените существующие файлы Joomla файлами из пакета обновления.

    Какие файлы менять? Если я заменю administrator 22mb на тот что из пакета 98 кб. ничего хорошего не выйдет. Никто толком объяснить не может. Везде одинаково пишут.
     
  5. Fanamura
    Offline

    Fanamura Доброта

    Регистрация:
    12.03.2007
    Сообщения:
    5 108
    Симпатии:
    159
    Пол:
    Мужской
    brustal, это где бы такую папку нашли? В дистрибутиве она больше весит
     
  6. Offline

    brustal Недавно здесь

    Регистрация:
    25.05.2009
    Сообщения:
    3
    Симпатии:
    0
    Joomla_1.5.7_to_1.5.8-Stable-Patch_Package
     
  7. chilly_bang
    Offline

    chilly_bang специалист

    Регистрация:
    30.04.2006
    Сообщения:
    1 545
    Симпатии:
    38
    Пол:
    Мужской
  8. Offline

    Dsv39 Недавно здесь

    Регистрация:
    08.07.2009
    Сообщения:
    1
    Симпатии:
    0
    а всётаки Joomla с 1.5.3 до 1.5.11???

    про не морочьте голову раз и навсегда - переходим по ссылке и получаем страницу с текстом "Joomla Magic Updater
    This extension has been unpublished for the following reason: no url"

    теперь вопрос, файлы и папки переписывать ВСЕ или всётаки выборочно? потому как на действующем сайте работает один из стандартных шаблонов, но немного модифицированный, т.е. если переписать из апдейта, то уже попортится (т.е. его не надо переписывать)...
    а как быть с другими файлами, там же тоже я что-то под себя ковырял и настраивал... или обновиться и по новой вспоминать что и где менял????

    ЗЫ. кстати, есть сайт на Жумле + Виртуемарт 1.1.0... в планах запустить полноценный инет магазин, но нет хорошего "управляющего", сам не успеваю да и делитант всётки в этом деле, может кто возьмется подсобить, доовести всё до ума!!???
     
  9. Offline

    Джон_Тут Недавно здесь

    Регистрация:
    26.03.2010
    Сообщения:
    66
    Симпатии:
    0
    Пол:
    Мужской
    Извините за мою прямоту. Но вот сейчас актуальна версия 1.5.17. Хотелось бы обновится. Пока ответа не нашёл как это нормально сделать. Только чушь какая-то.
    Те, кто создал Joomla - дебилы конченные. Всё просто.
    Самое тупое - НУ КАК МОЖНО СОЗДАТЬ ЧТО-ТО, ЧТО НЕЛЬЗЯ НОРМАЛЬНО И БЕЗ ГЕМОРРОЙНО ОБНОВИТЬ???!!!

    Не, ну не дебилы?! :(

    Тот компонент, который предлагали - платный и нафиг он не нужен.
    Вот нашёл ссылку на бесплатный и вроде как рабочий - http://extensions.joomla.org/extensions/core-enhancements/installers/9332

    Там последний комментарий такой: "Отлично обновился с 1.5.14 до 1.5.17. Вот чего и Вам желаю!

    Пост-Скриптум - Тестируйте сначала на локальном компьютере. Чтобы потом не плакать... :)
     
    Последнее редактирование: 09.05.2010
  10. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    "Все придурки, кроме Я"?
    C таким же успехом они могут назвать тебя дебилом, раз не можешь выполнить простую операцию - перезалить файлы.

    Если у кого-то и есть проблемы, то они сами себе их создали
     
  11. Offline

    Джон_Тут Недавно здесь

    Регистрация:
    26.03.2010
    Сообщения:
    66
    Симпатии:
    0
    Пол:
    Мужской
    Не согласен. Прежде чем что-то создавать, нужно подумать о будущем. Без геморройное обновление это то, что должно быть на первом месте - т.к. от этого зависит всё!
    Почему можно без проблем обновить практически любой модуль, а вот с обновлением у многих людей проблемы?
    Потому что это - геморр!

    А меня назвать дебилом они могут - только я за такие слова по зубкам даю очень быстро, т. к. на это у них причин нет, а вот у меня есть чтобы обзываться - и почему я уже объяснил.;)
    Это тупо создавать такого масштаба CMS и даже не сделать нормального и удобного автоматического обновления!
    Вот я о чём. Надеюсь Вы меня поняли. :)
     
  12. Offline

    Джон_Тут Недавно здесь

    Регистрация:
    26.03.2010
    Сообщения:
    66
    Симпатии:
    0
    Пол:
    Мужской
  13. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Я описал причину. Недостаточно? По твоей логике - "не можешь - дебил".
    А вообще, написал бы разработчикам на оффоруме, чем здесь флудить. ;) Скажи "правду-матку" им прямо в лицо! Зачем за спиной судачить?

    Не понял.
    В сказку попал? Нет универсального автоматического обновления. Да и движки с автообновлением можно перечислить по пальцам.

    Какой дебил поставил на локалке сервер без curl и не подумал о будущем?! :D

    Оффтопик (не в тему) - жми сюда!
     
  14. Offline

    Джон_Тут Недавно здесь

    Регистрация:
    26.03.2010
    Сообщения:
    66
    Симпатии:
    0
    Пол:
    Мужской
    А то вы не знаете какой? Опять же - РАЗРАБОТЧИК! Curl-то есть. Только вот нет нормального его подключения и выбора компонентов, которые тебе нужны. Я вот ставил всё чисто - а при подключении на 3х системах ошибка вылетает. И кто виноват - РАЗРАБОТЧИК!

    Вы хотите сказать, что разработчики такой мощной системы не могут сделать банального обновления для своего продукта?! Не смешите людей.;P


    Я ВАМ ТАК СКАЖУ (И НА ФОРУМЕ СКАЖУ РАЗРАБОТЧИКАМ JOOMLA) - НЕ УМЕЕШЬ - НЕ БЕРИСЬ!


    Если подразумевается обновляться и нет нормального и без геморройного обновления - любая прога - отстой на постном масле. Если бы я был программер я бы показал как надо. Но я, к сожалению, далёк от этого.
    Зато в своей области я так коряво никогда не делаю, не делал и делать не собираюсь, а тех, кто так делает, терпеть не могу и буду говорить, а не молчать.

    Это тоже самое что делать свою работу спустя рукава. Зачем Вам машина, к которой нет деталей или нельзя их починить?:[

    Вы даже наверное не пробовали программу которую я привёл по ссылке. А рассуждаете... :D
     
  15. Лат
    Offline

    Лат Звоните 8 (905) 778-52-44

    Регистрация:
    31.01.2007
    Сообщения:
    1 751
    Симпатии:
    113
    Пол:
    Мужской
    Значит так. Объясню суть.
    Первое. Различие между версиями внутри линейки касаются фиксов багов и безопасности. Ничего нового там нет. Почему обновление по FTP самая нормальная тема? Просто все эти компоненты обновления могут глючить НА ВАШЕМ хостинге, потому что много хостеров-школьников с кривыми ручками сейчас. Поэтому если бы разработчики сделали автоматический апдейт они бы стали ЗАЛОЖНИКАМИ хостеров. Кроме того никто не идеален и глюки бывают в версиях, я например сижу на 1.5.15 и не спешу обновляться пока.
     
  16. Offline

    Джон_Тут Недавно здесь

    Регистрация:
    26.03.2010
    Сообщения:
    66
    Симпатии:
    0
    Пол:
    Мужской
    Вопрос - ПОЧЕМУ? Насколько мне известно в версиях выше исправлено много дыр в безопасности и разработчики рекомендуют обновиться.

    На счёт хостингов-школьников. Это даже смешно. Т.к. если кто-то ищет "получше" и подешевле - то и ожидать ничего не стоит кроме как глюков и лажы. Правельно ведь?;)

    Граждане, пользуйтесь Дорогими Качественными и Зарекомендовавшими себя временем Хостинг-предприятиями!:)
     
  17. Offline

    cherry-marry Недавно здесь

    Регистрация:
    17.08.2010
    Сообщения:
    3
    Симпатии:
    0
    Пол:
    Женский
    Мой http://navadance.com.ua тоже до сих пор на Joomla 1.5.5. В свое время через известную дыру его несколько раз ламали. Потом я хотела было обновить до 1.5.8, но после безуспешных нескольких попыток забила на это аж до сегодняшнего дня. Теперь вот снова встала необходимость идти в ногу со временем, и хочется сразу обновить до 1.5.17, но опять, как я вижу, те же грабли. Из критически волнующих меня вопросов:

    1. У меня title, keywords и description страницы делались при помощи хака ядра, насколько помню, потому что тогда других нормальных вариантов не было. Что будет после обновления? Я так понимаю, все прописанные title, keywords и description у страниц попропадают?

    2. Сам шаблон писался под Джумлу еще до 1.5.5. Будет ли нормально работать, если обновить все-таки до 1.5.17?

    Заранее признательна за ваши ответы.
     
  18. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    cherry-marry, последняя версия - 1.5.20, до неё и надо обновлять.
    1. Найти хак для 1.5.20 или переделать старый хак под эту версию. Там не сложно.
    После обновления (даже без хака) данные не пропадают и остаются в базе до тех пор, пока не будет пересохранен пункт меню.
    2. Этого никто 100% не скажет. Должен работать.
     
  19. Offline

    Alen91 Недавно здесь

    Регистрация:
    14.02.2013
    Сообщения:
    3
    Симпатии:
    0
    Пол:
    Мужской
    А скажите пожалуйста, можно ли обновить joomla 2.5.9 до 3.0?
     
  20. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Alen91,
    1. Эта тема о другом.
    2. Ответ - можно, но не нежелательно.
     
  21. San4ozzZ
    Offline

    San4ozzZ Пользователь

    Регистрация:
    07.03.2011
    Сообщения:
    123
    Симпатии:
    0
    Пол:
    Мужской
    скажите а с 2.5.9 на 2.5.14 стоит обновляться ?
     

Поделиться этой страницей

Загрузка...