YOOlogin и некорректное отображение модуля (CSS-?)

Тема в разделе "Ошибки при работе с Joomla", создана пользователем GDA, 12.12.2008.

  1. Offline

    GDA Гость

    Здравствуйте!
    Помогите решить проблему с отображением картинок (иконок)..

    Проблема в том, что при установке любого модуля авторизации с применением css, модуль выглядит как стандартный.. Ощущение, что css на читается...

    Я решил установить (free) модуль авторизации YOOlogin:
    http://tools.yootheme.com/yootools/free-stuff/yoologin.html

    Модуль установился, но отображается без иконок, которые должны быть. Такое ощущение, что CSS не читается. Похоже, что и путь к картинкам, записанный в CSS-файле, тоже не виден системе.

    Как исправить ситуацию?

    Спасибо!

    ----------------
    На сайте установлена Джумла 1.0.15
     
  2.  
  3. Fanamura
    Offline

    Fanamura Доброта

    Регистрация:
    12.03.2007
    Сообщения:
    5 108
    Симпатии:
    159
    Пол:
    Мужской
    GDA, я точно помню, что в Index.php шаблона нужно прописать путь до css модуля, ищите в modules/mod_yoo_login/что-то там.css.php , этот файл нужно подключить как обычный css
     
  4. Offline

    GDA Гость

    Спасибо за ответ.
    Но в силу своей "чайниковости", о каком Index.php идет речь?

    Вот как выглядит содержимое папки /modules/mod_yoo_login/
    styles/
    tmpl/
    changelog.php
    helper.php
    index.html
    mod_yoo_login.css.php

    А мне нужно, чтобы CSS брались из
    /modules/mod_yoo_login/styles/quick/
    black/
    images/
    ie6hacks.css
    index.html
    style.css

    О каком Index.php вы говорите?
     
  5. Fanamura
    Offline

    Fanamura Доброта

    Регистрация:
    12.03.2007
    Сообщения:
    5 108
    Симпатии:
    159
    Пол:
    Мужской
    GDA, открываем /templates/ваш_шаблон/index.php
    перед </head> вставляем:
    <link rel="stylesheet" type="text/css" href="<?php echo $mosConfig_live_site;?> /modules/mod_yoo_login/mod_yoo_login.css.php"/>
    радуемся жизни
     
  6. Offline

    GDA Гость

    А не возникнет проблемы, если у там уже есть вот такая запись:
    <?php echo "<link rel=\"stylesheet\" href=\"$GLOBALS[mosConfig_live_site]/templates/$GLOBALS[cur_template]/css/template_css.css\" type=\"text/css\"/>" ; ?>


    Я добавил строку... но не помогло (((
     

Поделиться этой страницей

Загрузка...