Не загружаются фотографии

Тема в разделе "Datso Gallery", создана пользователем liga, 29.12.2008.

  1. liga
    Offline

    liga Пользователь

    Регистрация:
    21.10.2008
    Сообщения:
    495
    Симпатии:
    18
    Пол:
    Мужской
    В общем стоит датсо 1.6
    Раньше все работало шикарно. Но недавно пришлось перейти на новый хостинг, перенес системку и только недавно заметил один косяк. Не могу загрузить фотографии.
    Например создаю категорию, все ок, на сайте категория отображается, хочу загрузить фотографию, жму нормал аплоад, страница стандартной загрузки отображается. Делаю стандартные операции, печатаю название, выбираю категорию, выбираю файл с компа, жму загрузить, появляется картинка загрузки, далее переадресовывает на страницу /administrator/index2.php?task=uploadhandler а там пустота и тишина, а точнее белый экран.

    Какие есть предположения? у меня вот мысля что нужно страницы загрузки перезалить или чтото поменять в строках, но в галереии не компался и не стремлюсь, мало ли что не так сделаю =)
     
  2.  
  3. infoman
    Offline

    infoman Недавно здесь

    Регистрация:
    28.08.2007
    Сообщения:
    575
    Симпатии:
    12
    Пол:
    Мужской
    сам то книжки читаешь? :)

    проверь включен ли на новом хосте safe_mode (должен быть выключен)
    после чего проверь права на папке куда лоадятся картинки ....
     
  4. liga
    Offline

    liga Пользователь

    Регистрация:
    21.10.2008
    Сообщения:
    495
    Симпатии:
    18
    Пол:
    Мужской
    infoman, сайфмод включил в файле рнр.ини. Не помогло
    Просмотрел права доступа, все нормально drwxr-xr-x, с ними все оке.
    Проблема осталась актуальной :(

    Неа, ну правда бывает playboy, но там больше не читаю, а рассматриваю интересные картинки:D
     
  5. liga
    Offline

    liga Пользователь

    Регистрация:
    21.10.2008
    Сообщения:
    495
    Симпатии:
    18
    Пол:
    Мужской
    Еще и lightbox не пашет к сожалению :(
     
  6. infoman
    Offline

    infoman Недавно здесь

    Регистрация:
    28.08.2007
    Сообщения:
    575
    Симпатии:
    12
    Пол:
    Мужской
    он вообще то off должен быть :)
     
  7. liga
    Offline

    liga Пользователь

    Регистрация:
    21.10.2008
    Сообщения:
    495
    Симпатии:
    18
    Пол:
    Мужской
    infoman, Вот я невнимательный, ага, сеня в сведениях о системе и увидел что чет нето, ну значит он выключен, проблема актуальна....
     
  8. Asylum
    Offline

    Asylum специалист

    Регистрация:
    09.02.2007
    Сообщения:
    2 573
    Симпатии:
    152
    Пол:
    Мужской
    Если бы Safe mode был включен, то вообще вряд ли удалось установить компонент. А раз проблема возникла после смены хостера... То вернее всего дело в нем
     
  9. liga
    Offline

    liga Пользователь

    Регистрация:
    21.10.2008
    Сообщения:
    495
    Симпатии:
    18
    Пол:
    Мужской
    Asylum, Было много проблем с переносом и очень часто обвинялся именно хостер, но с хостером все в поряде, дело в компоненте, думаю перезалить некоторые файлы галереи, авось поможет...
     
  10. infoman
    Offline

    infoman Недавно здесь

    Регистрация:
    28.08.2007
    Сообщения:
    575
    Симпатии:
    12
    Пол:
    Мужской
    а мы говорим о переносе...
    если это перенос то ничего устанавливать ненужно
    вот пусть попробует установить что нить другое
    если не получится значит не соблюдаются требования
     
  11. infoman
    Offline

    infoman Недавно здесь

    Регистрация:
    28.08.2007
    Сообщения:
    575
    Симпатии:
    12
    Пол:
    Мужской
    Оффтопик (не в тему) - жми сюда!
     
  12. liga
    Offline

    liga Пользователь

    Регистрация:
    21.10.2008
    Сообщения:
    495
    Симпатии:
    18
    Пол:
    Мужской
    infoman, Эх, если придется ставить другую галерею то яж сдохну когда переносить туды 200 фоток которые находятся в одной папке и имеют ужасные названия...
     
  13. liga
    Offline

    liga Пользователь

    Регистрация:
    21.10.2008
    Сообщения:
    495
    Симпатии:
    18
    Пол:
    Мужской
    infoman, Ну предположим такую вещичку, после переезда поставил на сайт компонент видео http://gimnaziya-2.ru/index.php?option=com_seyret&Itemid=99
    Как видно из странички все видеоролики показываются нормально, но не это интересует, а то что они все загружались с компа, точно также как и скрины, вот специально проверил еще раз http://gimnaziya-2.ru/index.php?option=com_seyret&Itemid=99&task=videodirectlink&id=11
    Тоесть с настройками трабл нет, скорее всего с компонентом как я понимаю :(
     
  14. Offline

    mariczzz Недавно здесь

    Регистрация:
    02.01.2009
    Сообщения:
    2
    Симпатии:
    0
    Абсолютно такая же фигня.

    Joomla 1.0.12
    DatsoGallery 1.6.2
    На старом хостере все работало аки часы, при переезде на новый возник сабж. Игрался и настройками, и правами доступа на каталоги - не помогло ничего. Что, неужели так и придется сносить компонент?
     
  15. liga
    Offline

    liga Пользователь

    Регистрация:
    21.10.2008
    Сообщения:
    495
    Симпатии:
    18
    Пол:
    Мужской
    mariczzz, Я все никак не могу отойти от нг, но мне кажется, что в настройках компонента, а точнее в файлах конфигурации что-то с ссылками, но я в этом не уверен, а пока справляю трогать ничего не хочу :)
     
  16. liga
    Offline

    liga Пользователь

    Регистрация:
    21.10.2008
    Сообщения:
    495
    Симпатии:
    18
    Пол:
    Мужской
    Нашел решение этой проблемы:
    Для того, что при загрузке файла у вас не выскакивал белый экран, кто знает тот понял, вам необходимо сделать следующее:
    1)Найти файл images.datsogallery.php который находится в administrator/components/com_datsogalery
    2)Найти 85-87 строчку и закомментировать их следующим образом:
    Код (PHP):
    1. //if (!@imageantialias($destimage, true)) {
    2. //return false;
    3. //}

    3)Перезалить файл

    Проверено на себе, все работает, спасибо форуму поддержки датсогалереи![!]
     
  17. liga
    Offline

    liga Пользователь

    Регистрация:
    21.10.2008
    Сообщения:
    495
    Симпатии:
    18
    Пол:
    Мужской
    mariczzz, Решение этой проблемы как раз и было описано для ветки галереи 1.6.х
    Пробуй, да прибудет с тобой сила :)
     
  18. Offline

    mariczzz Недавно здесь

    Регистрация:
    02.01.2009
    Сообщения:
    2
    Симпатии:
    0
    Круто! Вроде заработало. Спасибо огромное

    ЗЫ. В исходниках Datso можно моск сломать. Особенно в период праздников.
     
  19. liga
    Offline

    liga Пользователь

    Регистрация:
    21.10.2008
    Сообщения:
    495
    Симпатии:
    18
    Пол:
    Мужской
    mariczzz, Или же в период после них, ибо он не лучше чем сам новый год :)
     
  20. infoman
    Offline

    infoman Недавно здесь

    Регистрация:
    28.08.2007
    Сообщения:
    575
    Симпатии:
    12
    Пол:
    Мужской
    liga, а ты вот посмотри чем функция imageantialias занимается наверняка ООП :)
    вот и увидишь чем ей новый хост не нравится :)
     
  21. liga
    Offline

    liga Пользователь

    Регистрация:
    21.10.2008
    Сообщения:
    495
    Симпатии:
    18
    Пол:
    Мужской
    infoman, Да я уже разрешил эту проблему, все нормально загружается :)
    А у сайта кстати уже PageRank=2 вот тока ТИЦ никак не может обновиться :)
     

Поделиться этой страницей

Загрузка...