Joomla 1.5 Режим совместимости (Legacy Mode)

Тема в разделе "Установка и обновление расширений Joomla", создана пользователем Timerlan, 01.02.2009.

  1. Offline

    Timerlan Недавно здесь

    Регистрация:
    08.01.2009
    Сообщения:
    15
    Симпатии:
    0
    Пол:
    Мужской
    Почему когда я начинаю устанавливать FireBoard, мне выдаёт вот эту ошибку?

    Вам необходимо включить Режим совместимости (Legacy Mode). Для этого необходимо опубликовать системный мамбот Legacy.
    Сообщение
    Установить Компонент: Ошибка

    ЧТО ЭТО ЗНАЧИТ???
     
  2.  
  3. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Идешь в список плагинов и включаешь плагин Legacy (он же плагин Обратная совместимость)
     
    andrewts нравится это.
  4. Azazello
    Offline

    Azazello Недавно здесь

    Регистрация:
    24.03.2007
    Сообщения:
    190
    Симпатии:
    4
    Пол:
    Мужской
    Проблема с включенным Legacy Mode - белый экран. (Joomla 1.5.9, Fireboard 1.0.5 RC2) Включал функцию отладки результат тот же - белый экран. Все настройки php.ini связанные со скоростью исполнения и размером памяти стоят на максимуме. Есть какие-нибудь версии? Заранее спасибо.
     
    Последнее редактирование: 15.02.2009
  5. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Белый экран при открытии форума или вообще везде? В первом случае причина не в режиме обратной совместимости.
    Включи отображение ошибок и разбирайся. Подробности в FAQ
     
  6. Azazello
    Offline

    Azazello Недавно здесь

    Регистрация:
    24.03.2007
    Сообщения:
    190
    Симпатии:
    4
    Пол:
    Мужской
    Цитирую себя:
    ...в смысле белый экран. С отключенным "Legacy" сообщение о ошибке совместимости.
    FAQ? перечитал в N-й раз :) Зачем? Все остальное (нужное) работает и ставится с пол тыка.

    У меня есть предположение что где-то здесь проблема (сервак - x64, PHP5) и не причина, но (ubuntu) ...ищу варианты решения.
     
    Последнее редактирование модератором: 05.04.2014
  7. Dead Krolik
    Offline

    Dead Krolik специалист

    Регистрация:
    13.04.2007
    Сообщения:
    3 688
    Симпатии:
    101
    Пол:
    Мужской
  8. Offline

    MiraMaX166 Недавно здесь

    Регистрация:
    01.12.2009
    Сообщения:
    4
    Симпатии:
    0
    Пол:
    Мужской
    А я не могу в модулях найти Legacy Mode. В плагинах (их 25 по дефолту) ничего подобного нет... Как быть?
     
  9. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
  10. Offline

    MiraMaX166 Недавно здесь

    Регистрация:
    01.12.2009
    Сообщения:
    4
    Симпатии:
    0
    Пол:
    Мужской
    Уже нашел, прошу прощения... Привык я к vBulletin и DLE...

    Joomla - это как мясорубка для мозга...
     
  11. Offline

    StepanR Недавно здесь

    Регистрация:
    05.12.2009
    Сообщения:
    11
    Симпатии:
    0
    Пол:
    Мужской
    У меня System - Legacy включен, а virtuemart все равно не работает:(

    пишет, что расширение требует lagacy mode
     
    Последнее редактирование модератором: 05.12.2009
  12. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    > пишет, что расширение требует lagacy mode
    так наверно не virtuemart требует. Ему оно не надо, если это последняя версия
     
  13. Offline

    StepanR Недавно здесь

    Регистрация:
    05.12.2009
    Сообщения:
    11
    Симпатии:
    0
    Пол:
    Мужской
    версия 1.0.15..требует и не работает...
     
  14. Offline

    StepanR Недавно здесь

    Регистрация:
    05.12.2009
    Сообщения:
    11
    Симпатии:
    0
    Пол:
    Мужской
    [​IMG]
    -вот так!
    [​IMG]
     
    Последнее редактирование модератором: 26.11.2014
  15. Offline

    StepanR Недавно здесь

    Регистрация:
    05.12.2009
    Сообщения:
    11
    Симпатии:
    0
    Пол:
    Мужской
    После установки virtuemart появляется окно с неправильной кодировкой, потом то жу самое окно возикает, если выбрать virtuemart в компонентах, только на русском. Там при нажатии на любую кнопку вылезает окно, где пишется, что все установлено, затем удалены архивы (или что там) После этого при выбору в компонентах virtuemart не появляется ничего.
     
    Последнее редактирование: 06.12.2009
  16. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    StepanR, зчемтебе эта древность? Последняя версия 1.1.4
     
  17. Offline

    StepanR Недавно здесь

    Регистрация:
    05.12.2009
    Сообщения:
    11
    Симпатии:
    0
    Пол:
    Мужской
    Спасибо, теперь работает!
     
  18. Offline

    Gvozd12 Недавно здесь

    Регистрация:
    09.12.2009
    Сообщения:
    4
    Симпатии:
    0
    Пол:
    Мужской
    После публикации системного мамбота Legacy в админке Joomla 1.5.14 пропало главное меню. подскажите как выключить Legacy Mode или где поправить отоброжение главного меню в админке?
     
  19. Offline

    letout Недавно здесь

    Регистрация:
    23.05.2010
    Сообщения:
    1
    Симпатии:
    0
    Пол:
    Мужской
    Установил себе форум FireBoard_1.0.4_Aleko_Edition_Russian, добавил пункт в главное меню. Но при нажатии выходит ошибка

    Deprecated: Assigning the return value of new by reference is deprecated in Z:\home\joomla\www\components\com_fireboard\fireboard.php on line 792
    Table 'joomla.jos_fb_whoisonline' doesn't exist SQL=INSERT INTO jos_fb_whoisonline (`userid` , `time`, `what`, `task`, `do`, `func`,`link`, `userip`, `user`) VALUES ('0', '1274596941', 'Главная','','','','/index2.php?option=com_fireboard&Itemid=19', '127.0.0.1', '0')Serious db problem:Table 'joomla.jos_fb_users' doesn't exist SQL=SELECT max(posts) from jos_fb_users

    Что делать? Как быть?
     
  20. Val Rubis
    Offline

    Val Rubis Недавно здесь

    Регистрация:
    15.10.2009
    Сообщения:
    44
    Симпатии:
    2
    Пол:
    Мужской
    Поставил Joomla 1.5.21, скачанныый с этого сайта, LEGACY MOD включен, но не активен, т.е. не возможно его отключить. И нет надписи, что он действительно работает (а он НЕ работает). Ставлю Joomla Explorer 1.6.3, на что компонент ругает на необходимость включения LEGACY MOD.
    Как получить достпуп к неактивному, но включенному LEGACY MOD?
     
  21. OlegM
    Offline

    OlegM Russian Joomla! Team Команда форума

    Регистрация:
    12.04.2007
    Сообщения:
    4 356
    Симпатии:
    370
    Пол:
    Мужской
    Что за зверь?
     

Поделиться этой страницей

Загрузка...